Comunidad Gambas-es

Versión completa: Problemas con WebView (gb.qt4.webkit)
Actualmente estas viendo una versión simplificada de nuestro contenido. Ver la versión completa con el formato correcto.
Buenas he actualizado recientemente a la versión 3.16.1 y tengo problemas solo al visualizar contenido en un componente webview que construía de forma dinámica para la visualización de gŕaficas.
Alguna recomendación??
Gracias.
Puedo volver a alguna versión en la que este componente esté estable??
Alguna idea, consejor?
Hola Calcena, coméntanos un poco mas sobre el asunto, por ejemplo es algo de producción o de experimentación ya que si es de producción te recomiendo que no uses la versión 3.16 sino la 3.15.
(14-06-2021, 21:28)calcena escribió: [ -> ]Puedo volver a alguna versión en la que este componente esté estable??
Si puedes volver, pero dependerá de tu sistema, manjaro, debian, ubuntu.
Si usas ubuntu y el PPA de gambasteam probablemente no puedas volver a la misma versión que tenias antes.
Tal vez usando:
Bash
  1. sudo add-apt-repository ppa:gambas-team/gambas-beta
  2. sudo apt-get update


Puedas volver a la versión 3.15.9 pero no lo probé, así no tengo idea de los resultados.
Luego en caso que no estés en producción puedes seguir con la versión 3.16 y reportar los errores que vas encontrando en el bugtracker ya que se vienen corrigiendo errores constantemente y, espero, que se llegue a una versión mas estable pronto.
Saludos.
Gracias tincho, es un desarrollo propio, por lo que tampoco es grave dentro de que utilizo mucho dos programas desarrollados con el sistema de webview para poder visualzar en formularios diagramas, que siempre dan más infomación visual de resultados.
El tema de volver a una versión anterior, la 3.15.9 lo miraré a ver que puedo hacer si me es posible.
Y el tema del bugtracker, dónde podría conseguir la url para registrarme y informar, más que nada porque creo que es una cosa que se utilizará en muchos proyectos y sería importante que funcionase, o saber si se han cambiado algún tipo de parámetro que esté afectando al comportamiento del componente.
Saludos y gracias.
(19-06-2021, 14:27)calcena escribió: [ -> ]Gracias tincho, es un desarrollo propio, por lo que tampoco es grave dentro de que utilizo mucho dos programas desarrollados con el sistema de webview para poder visualzar en formularios diagramas, que siempre dan más infomación visual de resultados.
Si, los diagramas son muy buenos para mostrar cierta información.
(19-06-2021, 14:27)calcena escribió: [ -> ]El tema de volver a una versión anterior, la 3.15.9 lo miraré a ver que puedo hacer si me es posible.
Suponiendo entonces que usas unbuntu o algo derivado, y usas el PPA, no puedes volver a instalar por este medio la versión anterior la 3.15.9 , mas estable, porque el PPA sencillamente ya no tiene esa versión sino la 3.16.
Otra solución que se me ocurre es que te descargues la versión 3.15.2 de gitlab y la compiles pero ya es algo mas laborioso (no tanto)
https://gitlab.com/gambas/gambas/-/tree/3.15.2
(19-06-2021, 14:27)calcena escribió: [ -> ]Y el tema del bugtracker, dónde podría conseguir la url para registrarme y informar, más que nada porque creo que es una cosa que se utilizará en muchos proyectos y sería importante que funcionase, o saber si se han cambiado algún tipo de parámetro que esté afectando al comportamiento del componente.
El bugtracker es un ben canal para reportar errores o sugerir cambios, he visto solucionar temas en cuestión de horas. Para registrarte:
http://gambas.sourceforge.net/en/main.html#
Algunos usuarios han tenido inconvenientes y no se han podido registrar correctamente, si fuera el caso avisa por aquí o envía un email a la lista internacional explicando el problema.
user@lists.gambas-basic.org
Saludos.