Comunidad Gambas-es

Versión completa: Instalando dependencias para instalar Gambas3 desde fuente. SOLUCIONADO
Actualmente estas viendo una versión simplificada de nuestro contenido. Ver la versión completa con el formato correcto.
Buenas!.

La Linux Mint 20.3 es equivalente a Ubuntu Focal Fossa (20.04)

He seguido las instrucciones de la web de Gambas, añadiendo sudo a todo esto:

Bash
  1. sudo apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libzstd-dev libmysqlclient-dev unixodbc-dev libpq-dev libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-private-dev libpoppler-glib-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-2.6-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev qtwebengine5-dev libwebkit2gtk-4.0-dev git



Y da problemas, se bloquea el proceso de instalación de paquetes, como si hubiese a la vez dos "apt-get".
Por un lado la actualización y por otro lado la instalación. Debería acabar un proceso y continuar el otro.

He tenido que eliminar todo esto:
Bash
  1. apt-get update && DEBIAN_FRONTEND=noninteractive



Y dejar el resto de instrucciones. Eso no me ha creado problemas en Linux Mint 20.3. A ver si va ser un problema para el resto de Gamberos.

Solo me ha pasado con la instalación de las dependencias de Gambas3. Algo tiene las instrucciones que no va del todo.
Ya lo tengo instalado pero lo voy a intentar con las que muestra la web. Para mostraros el error.
 
Cita:E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock-frontend» - open (13: Permiso denegado)
E: No se pudo obtener el bloqueo de la interfaz dpkg (/var/lib/dpkg/lock-frontend). ¿Es usted superusuario?

Por que ya hay otro proceso...
Actualizo y no da ningún error. Lo crea las instrucciones de la instalación de las dependencias.

Saludos
Al hacer:

Bash
  1. sudo apt-get update && apt-get upgrade



Crea el mismo problema:
 
Cita:E: No se pudo abrir el fichero de bloqueo «/var/lib/dpkg/lock-frontend» - open (13: Permiso denegado)
E: No se pudo obtener el bloqueo de la interfaz dpkg (/var/lib/dpkg/lock-frontend). ¿Es usted superusuario?

El siguiente apt-get upgrade debería haber sido:
Bash
  1. sudo apt-get update && sudo apt-get upgrade



Esa es la solución, me faltó usarlo en la segunda instrucción de apt-get con las dependencias.
Debería haber incluido la otra instrucción con sudo, pero parece que no es así, son dos instrucciones independientes.
(23-06-2022, 22:02)Shell escribió: [ -> ]son dos instrucciones independientes


Exacto, el && concatena comandos pero espera a que el primero termine la ejecución para comenzar el siguiente y por eso necesitas el sudo también, porque son independientes.

Saludos