Comunidad Gambas-es
PSeInt - Pseudo interprete - Versión para impresión

+- Comunidad Gambas-es (https://gambas-es.org)
+-- Foro: Linux (https://gambas-es.org/forumdisplay.php?fid=9)
+--- Foro: Programación en otros lenguajes (https://gambas-es.org/forumdisplay.php?fid=12)
+---- Foro: C/C++ (https://gambas-es.org/forumdisplay.php?fid=15)
+---- Tema: PSeInt - Pseudo interprete (/showthread.php?tid=395)



PSeInt - Pseudo interprete - tincho - 05-05-2021

Hola amigos.
Como didáctico es didáctico, desde la charla en otro tema sobre programación en español me puse a revolver la red de redes y encontré algunas cosas interesante una es PSeudo Intérprete, PSeInt.
https://es.wikipedia.org/wiki/PSeInt
Este es mi primer programa y pantallazo:
[Imagen: skhfoQv.png]
Saludos.


RE: PSeInt - Pseudo interprete - tercoide - 05-05-2021

Muy bueno para niños en edad de escuela primaria


RE: PSeInt - Pseudo interprete - tincho - 05-05-2021

(05-05-2021, 14:46)tercoide escribió:  Muy bueno para niños en edad de escuela primaria

Si, yo pensé lo mismo. Bueno es una herramienta mas para educar.
Saludos.


RE: PSeInt - Pseudo interprete - Shell - 06-05-2021

Hola!.

El ejemplo es muy sencillo. Big Grin

Yo no díría que sea para niños.  Shy
Es para cualquier programador que comienza y no quiere complicarse con sintaxis de lenguajes.

Lo he usado bastante. Le encontré un problema con las funciones pero ahora no recuerdo si era con los argumentos o
con el retorno. A ver si este era el ejemplo que hice en su día.
Cita: 
Funcion numeros<-Ordena(numeros, maximo)
        
    Definir cambio Como Logico;
    definir a Como Entero;
    definir aux Como Entero;
    
    cambio <- Verdadero;
    
    Mientras  cambio Hacer
        cambio <- Falso;
        // Un indice menos para poder comparar con el número siguiente sin salirse de los inidces del array.
        para a desde 1 hasta maximo con paso 1
            si numeros[a] > numeros[a + 1] Entonces                
                aux <- numeros[a];
                numeros[a] <- numeros[a + 1];
                numeros[a + 1] <- aux;
                cambio <- Verdadero;
            FinSi            
        FinPara        
    FinMientras
        
FinFuncion

Algoritmo OrdenarArray
    
    Dimension valores[5];
            
    valores[1] <- 7;
    valores[2] <- 10;
    valores[3] <- 23;
    valores[4] <- 89;
    valores[5] <- 10;
        
    valores <- Ordena(valores, 5);
    
    para a desde 1 hasta 5 con paso 1
        escribir ConvertirATexto(valores[a]) + " ",Sin Saltar;
    FinPara
    
    
FinAlgoritmo



[Devuelve este error:
Cita:Lin 35 (inst 1): ERROR 200: Faltan subindices para el arreglo (VALORES)



Creo que es cuando se le pasa un array.

Para niños estuve hace unos días en el que programabas los movimientos del robot del Despertar de la Fuerza de Star Wars.
Me creía que era otra cosa. Smile

Era como Scratch.

Saludos

Variable cambiada de "i" a "a" que el editor le tiene manía con los indices.. Dodgy


RE: PSeInt - Pseudo interprete - Shell - 06-05-2021

Quiere un elemento concreto por lo que parece.

[Imagen: Pg5Ss87.png]

El indice de los array pueden configurarse para que comiencen desde 0 o desde 1.

[Imagen: 38YFUYf.png]

Hay perfiles de una gran cantidad de escuelas. Con tal de ver su escudo.. Tongue

Saludos


RE: PSeInt - Pseudo interprete - tincho - 06-05-2021

“Nunca confíes en un ordenador que te pueda lanazar a ti por la ventana” Morpheus
[Imagen: cCaVZfI.png]


RE: PSeInt - Pseudo interprete - Shell - 06-05-2021

(06-05-2021, 15:58)tincho escribió:  “Nunca confíes en un ordenador que te pueda lanazar a ti por la ventana” Morpheus

Big Grin Big Grin