Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Actualicé Mageia de 7 a 8 y ahora Gambas no corre
#1

Fue realmente sencillo actualizar Mageia7 a 8 siguiendo las recomendaciones de los propios desarrolladores en su página en español.

Una vez concluida la instalación vía Internet de Mageia8, procedí a probar todas mis aplicaciones que uso regularmente: Chrome, Geany, VS Code, Lampp, Quadrapassel, Solitario, etc y se ejecuta bien.

Pero al arrancar Gambas sale una mensaje de error:

[Imagen: f0qAtHj.png]

Como este mensaje no dice nada útil (según yo), traté de ejecutar Gambas3 desde consola:

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
CDocumentation.Reset.1136: #12: Not an object
CDocumentation.Reset.1136 CDocumentation._new.374 Project.Main.358 

Ahora si dice algo....mmm...como se soluciona esto?....Por favor alguien que me eche una mano.....Quiero probar alguna manera antes de aplicar "purge" o "remove", porque de hacerlo así no aprendería nada....

Gracias...

Es mejor saber un poco de todo, que todo de muy poco. Lo primero, garantiza la supervivencia humana.
    ¡Gracias!
#2

Hola

Con el botón derecho del mouse encima del icono lanzador de gambas, debería salir un menú contextual en el que puedes elegir con qué toolkit arrancar gambas.

Prueba con todas las opciones para ver qué resultado obtienes.

Por el mensaje de error, puede ser que la versión instalada de gambas no haya sido compilada para Wayland. Si nada de eso funciona, yo desinstalaría gambas y volvería instalar de nuevo.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#3

(22-08-2021, 17:20)jguardon escribió:  Con el botón derecho del mouse

Gracias Jguardon:

Al hacer lo del botón únicamente salen "Ventana Nueva" y "Quitar de los favoritos"...traté oprimiendo Shifht, o Alt o Ctrl, pero tampoco sale un submenú....

Voy a esperar un poco por si se te ocurre alguna alternativa mas, antes de desinstalar....o a alguno de los asistentes al foro,,,,,

Pendientes....

(22-08-2021, 17:20)jguardon escribió:  gambas no haya sido compilada para Wayland.

Me da la impresión que modificando un archivo de la instalación de gambas3, ahí donde está:

XDG_SESSION_TYPE=wayland ; //on Gnome.

Y adicionar....

QT_QPA_PLATFORM=wayland

O algo que tenga que ver con estos 2 "settings"....pero Cual será ese archivo?

Es mejor saber un poco de todo, que todo de muy poco. Lo primero, garantiza la supervivencia humana.
    ¡Gracias!
#4

Cita:Al hacer lo del botón únicamente salen "Ventana Nueva" y "Quitar de los favoritos"...traté oprimiendo Shifht, o Alt o Ctrl, pero tampoco sale un submenú....
Copia el acceso directo del menú al escritorio y prueba entonces lo del botón derecho.

Saludos

No podemos regresar
    ¡Gracias!
#5

(22-08-2021, 17:54)Shordi escribió:  Copia el acceso directo del menú al escritorio y prueba entonces lo del botón derecho.

Bueno, si está usando Gnome3 como escritorio, eso no es posible, creo. Alfredo no ha precisado cuál escritorio está usando.

Lo que está claro es que es muy posible que sea la introducción de Wayland en Gnome3 en la versión 8 de Mageia, que sin embargo he leído que puede iniciarse con Xorg si uno lo desea... no estoy yo muy ducho en esos menesteres, de momento.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#6

(22-08-2021, 18:23)jguardon escribió:  si está usando Gnome3 como escritorio, eso no es posible,

Efectivamente, al migrar a Mageia 8 se instaló el Wayland como gestor de ventanas. Estuve tratando de aplicar la recomendación de Shordi pero sin éxito, como bien dices.

Incluso un archivo que tenía en el escritorio (un simple archivo de texto) cuando era Mageia 7, ahora en 8 no lo veo en el Escritorio. Pero si navego con permisos de sudo usando Nautilus, si puedo ver dicho archivo pero ahora como ".archivo.txt", es decir oculto.

Tengo la duda si GNOME y Wayland son 2 entornos diferentes, pero indagando un poco en entornos encuentro que Wayland no aparece en la siguiente lista:
 afterstep
awesome
cinnamon
dwm
enlightenment
fluxbox
fvwm2
fvwm3
fvwm-crystal
gnome-classic-session
gnome-session
i3
icewm-light
kodi
lxde-common
lxqt-session
matchbox-desktop
mate-session-manager
mythtv-frontend
openbox
pekwm
plasma-mediacenter
plasma-workspace
remmina
spectrwm
sugar
swm
windowmaker
xfce4-session

Entonces, que pasa si quito Wayland y uso Cinnamon o XFCE o MATE???...estoy algo confundido....

Es mejor saber un poco de todo, que todo de muy poco. Lo primero, garantiza la supervivencia humana.
    ¡Gracias!
#7

Porque Wayland no es un entorno de escritorio, sino un gestor de ventanas, como lo es X11. He leído que el usuario puede elegir entre iniciar Gnome3 usando Wayland o Xorg, pero no he profundizado más. Si quieres seguir probando Gnome3, intenta que inicie con X11/Xorg y no con Wayland, de esa forma casi seguro que Gambas vuelva a funcionar. La verdad que una búsqueda rápida en Internet para intercambiar ambos gestores no ha arrojado demasiada luz y no puedo darte una respuesta útil, lo siento.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
[-] Los siguientes 1 usuarios dice gracias a jguardon por este post:
  • AlfredoSC
    ¡Gracias!
#8

Hola Alfredo.
Esto me trae recuerdos de mis primeros tiempos en GNU/Linux ya que Mandrake Linux (de donde proviene Mageia) fue la primera distribución GNU/Linux que instale hace mucho mucho tiempo Smile
Bien, al tema. Repasando lo que indicas estas usando gnome3 (yo también pero en debian) y me paso algo similar respecto a Wayland, concretamente los programas de grabación de escritorio no funcionaban, así que al iniciar el escritorio, al entrar en la sesión, elegía X11 en vez de wayland, estimo que esta opción debe estar disponible también en tu sistema y probablemente solucione el inconveniente.
Luego respecto a gambas, tal vez desinstalando y volviendola a instalar se solucione el tema.
Saludos.

1 Saludo.
[-] Los siguientes 1 usuarios dice gracias a tincho por este post:
  • AlfredoSC
    ¡Gracias!
#9

(23-08-2021, 12:30)tincho escribió:  , tal vez desinstalando y volviendola a instalar se solucione el tema.

Pues ya busqué alguna solución y no la veo en la web. Pero hay que seguir buscando.

Finalmente desinstalé gambas3. Lo volví a instalar y no funcionó, pues manda el mismo mensaje.

Bueno, pues no usaré gambas en Mageia 8, hasta que salga a la luz algún método o parche para solucionarlo de manera automática o manual, al gusto del usuario.

Saludos...

Es mejor saber un poco de todo, que todo de muy poco. Lo primero, garantiza la supervivencia humana.
    ¡Gracias!
#10

otra opcion es escribir en la lista internacional a ver si alguien te da una solucion

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje
Último mensaje por tincho
16-05-2021, 13:16

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)