Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

¿Os funciona Gambas en Ubuntu 22.04?
#11

(09-05-2022, 11:06)cogier escribió:  Es una crítica justa. He añadido un informe de errores. Simplemente me sorprendió la total falta de interés de la lista de correo.  
Si, coincido contigo en que es un reclamo justo, pero insisto en que el equipo de gambas es decir Boenoît y los demás que aporten código a gambas no mantienen el paquete ubuntu.
No se las razones de que esto sea así, puede ser la falta de tiempo, o puede ser que los de ubuntu decidan que esto sea así no lo se.
Pero alguna razón hay porque el equipo de gambas si que mantiene un PPA que funciona bien, como tu has dicho antes.
Respecto a que nadie respondiera tu correo tal vez de deba a que el correo decía "solo para que ustedes sepan ...."
Cita:Hi,
Just to let you know that the default Gambas (3.16.3) on the Kubuntu 22.04 beta crashes with 'The program has returned the value: 1". This is with a new GUI program with no code or Toolbox item added to the form.
Sinceramente si me llega un correo de este tipo lo tomo como algo informativo a lo que no hay que responder, o a lo sumo se puede decir gracias por el aviso pero poco mas.
Yo en tu lugar pondría algo como ¿Hay al gun plan para solucionar que el paquete de ubuntu 22.04 no funcione? O algo por el estilo.
Regards.

Por otra parte, el equipo de desarrollo de gambas no hace (hasta donde yo se) parches para las versiones anteriores a la de desarrollo, es decir si hay un error en la 16.3 eso se queda así para siempre y tienes que actualizar de version pero no lo puedes hacer porque el paquete "oficial" no esta actualizado.
Esto sucede especialmente con ubuntu, porque tomas los paquetes de la version estable de debian y los pone en su distribución.
Los que empaquetan gambas para debian lo hacen en la version Testing no en la estable.
No sucede lo mismo con Arch, manjaro etc.

1 Saludo.
    ¡Gracias!
#12

Tengo entendido que Ubuntu toma los repósitos de la versión Testing de Debian, no de la versión estable. Lo que pasa es que cuando se congela la nueva versión de Ubuntu, también se congelan los paquetes que toma de Debian y no se cambian a no ser que tengan que ver con la estabilidad del sistema operativo o sean programas muy usados, como LibreOffice o similares.
 
Con todo esto supongo que no será fácil que admitan una corrección en un paquete que no es crítico, supongo que por eso no se arreglan estos fallos.

Un saludo.

P.D.: Solo por probar he desinstalado la versión de Gambas de PPA y he vuelto a instalar la versión de los repósitos oficiales y si que funciona. El caso es que hay que abrirlo con el botón derecho sobre el lanzador y escoger QT5. No sabía de este detalle por eso instalé la del PPA, así que tecnicamente la versión de los repósitos si funciona. ¿Habrá alguna forma de abrir  Gambas siempre con la versión de QT5 sin tener que hacer click derecho en el lanzador? Voy a investigar.

P.D.: He estado mirando y hay que editar el archivo gambas3.desktop que se encuentra en /usr/share/applications y borrar las opciones de lanzamientos dejando solo las de QT5
[Imagen: 0bJ0kOp.png]
Así solo con hacer click en el lanzador se abre la versión de QT.

P.D.: Acabo de comprobar que usando el componente gb.gui o gb.gtk3 el programa también se cae, así que solo funciona usando el componente gb.qt5
    ¡Gracias!
#13

Señalo esto:

   https://www.gambas-it.org/smf/index.php?...3#msg51623


Por lo que atañe el archivo gambas3.desktop, yo uso:
[Imagen: TtacRlK.png]

"Los horizontes perdidos nunca regresan. " (F. Battiato, La stagione dell'amore, 1983)

"Las ondas nunca regresan. " (Genesis: Ripples - A trick of the tail, 1976)
[-] Los siguientes 3 usuarios dicen gracias a vuott por este post:
  • guizans, Shordi, tincho
    ¡Gracias!


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje
Último mensaje por Shell
26-09-2021, 00:39

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)