Versiones, Aplicaciones Para Las Administraciones Públicas


Objetivo: Versiones, Aplicaciones Para Las Administraciones Públicas
Buenas!.

A la hora de rellenar una solicitud para la bolsa de trabajo del Servicio Andaluz de Salud me encontré un problema con la versión de Java y el navegador.
En este caso se necesitaba tener un navegador con el soporte de Java. Bien yo no sabía como activarlo y no investigué lo suficiente.

Ademas de tener certificado electrónico la documentación que envíes debe estar firmada por una aplicación. Eso añade un certificado para usar
con los navegadores FireFox o Chrome.

La aplicación que usa se llama Auto-firma. Si no la usas directamente en el navegador, existe la aplicación java con su interfaz que permite firmar
el documento que envíes, que así fue como lo hice.

Problema: Esta aplicación funciona con JDK8 y no con JDK11.
¿ Y ?. ¿ Cómo es posible que no se actualice a una versión superior ?. Siendo solicitada o demandada para fines necesarios.

Tuve que cambiar la versión de java desde la consola:

sudo update-alternatives --config java


Y con eso pude hacer uso de la aplicación.

Añadiría de forma surrealista. Un programa que está hecho con gambas 2 y que luego no funcionase en gambas 3.
Ok, puede darse el caso, pero ¿ y su mantenimiento ?.

Saludos

última edición por Shell el Miercoles, 12 Febrero 2020, 11:19; editado 2 veces
Objetivo: Re: Versiones, Aplicaciones Para Las Administraciones Públicas
Shell escribió:  


Añadiría de forma surrealista. Un programa que está hecho con gambas 2 y que luego no funcionase en gambas 3.
Ok, puede darse el caso, pero ¿ y su mantenimiento ?.

Saludos


Mirá guopo y perdon por lo de guopo

No te preguntes eso, hombre de Dios, hay miles de motivos. Ejemplos:

1. Que una versión superior implica firmar algo con el fabricante.
2. Que provoque mas inseguridad que seguridad.
3. Que tenga librerías marcadas como obsoletas y no sean ya accesibles, en fin, etc, etc, etc.

Yo no prejuzgo a los desarrolladores, seguro que para todo tiene un motivo y un porque, incluso la ignorancia, ¿no crees?

Saludos, joven.

Perfil MP  
Objetivo: Re: Versiones, Aplicaciones Para Las Administraciones Públicas
GambaFeliz:


gambafeliz escribió: [Ver mensaje]

Mirá guopo y perdon por lo de guopo


Ajá, ya veo que no soy el único que se le enreda los dedos al escribir!.
Crearé otro post sobre este problema...pues claro!.

gambafeliz escribió: [Ver mensaje]

No te preguntes eso, hombre de Dios, hay miles de motivos. Ejemplos:

1. Que una versión superior implica firmar algo con el fabricante.


Y pagar algo más...

gambafeliz escribió: [Ver mensaje]

2. Que provoque mas inseguridad que seguridad.


Un gran aspecto a controlar. Pero entonces los desarrolladores serian reacios a las novedades.

gambafeliz escribió: [Ver mensaje]

3. Que tenga librerías marcadas como obsoletas y no sean ya accesibles, en fin, etc, etc, etc.


Creo que esa es la mejor respuesta. Pero eso puede ser un problema grave de seguridad.

gambafeliz escribió: [Ver mensaje]

Yo no prejuzgo a los desarrolladores, seguro que para todo tiene un motivo y un porque, incluso la ignorancia, ¿no crees?


No digo que sean los malos de la película. Los motivos pueden ser muchos. Como somos desarrolladores a distintos
niveles, lenguajes, motivos, pues que mejor que preguntar a otros desarrolladores. Y sobre todo a desarrolladores
de Java.

Algo que si puedo añadir es que no estoy acostumbrado aun a las aplicaciones que van dirigida a un navegador
por eso también pregunto. Ya tendré tiempo de ver las diferencias y lo que conlleva eso. Si es que hay algo más
que programar. Lo que significa hacer algo para un navegador u otro, etc, etc. Y hay una política por medio.

Saludos


Página 1 de 1


  
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario

   

Está utilizando la versión (Lo-Fi). Para ver la versión completa del foro, haga clic aquí.

Powered by Icy Phoenix based on phpBB
Design by DiDiDaDo

Página generada en:: 0.0689s (PHP: -6% SQL: 106%)
Consultas SQL: 21 - Debug off - GZIP Activado