Uso De Oracle Java En Linux Mint


Objetivo: Uso De Oracle Java En Linux Mint
Hola, compañeros:
Tengo que hacer uso de java en una aplicación del OAN Madrid y, la verdad, he seguido las instrucciones de instalación tanto de la página de java como las de otras que aconsejan usar ppa y no he logrado nada. ¿Alguien tiene idea de cómo se utiliza con Firefox en Linux Mint?
Gracias de antemano.

Objetivo: Re: Uso De Oracle Java En Linux Mint
Grandamakulo escribió:  
Hola, compañeros:
Tengo que hacer uso de java en una aplicación del OAN Madrid y, la verdad, he seguido las instrucciones de instalación tanto de la página de java como las de otras que aconsejan usar ppa y no he logrado nada. ¿Alguien tiene idea de cómo se utiliza con Firefox en Linux Mint?
Gracias de antemano.

Así como planteas el tema no se me ocurre como ayudarte, por ejemplo no se que es oan madrid (deberías poner el link de la página tal vez)
¿Es algo así como operar en hacienda con certificado electrónico?
Saludos.

Perfil MP  
Objetivo: Re: Uso De Oracle Java En Linux Mint
tincho escribió:  

Así como planteas el tema no se me ocurre como ayudarte, por ejemplo no se que es oan madrid (deberías poner el link de la página tal vez)
¿Es algo así como operar en hacienda con certificado electrónico?
Saludos.


Lo siento: ha sido una cuestión —demasiado habitual en mí— de conocimiento subjetivo. El OAN es el Observatorio Astronómico Nacional. En su página de Efemérides —
http://www.oan.es/servidorEfem/ — permite obtener determinadas informaciones de manera directa y otras tantas a través de cálculo dinámico basado en Java. Por ejemplo, en esta misma página, pulsad en «Eventos» y dentro de esta pestaña, pulsad en cualquiera de los eventos listados. Aparecerá una ventana nueva que en el ordenador del trabajo con W7 funciona —a la hora del café, malpensados—, pero en el personal con Linux Mint me dice que necesito Java 1.6 mínimo.

Espero haber sido algo más concreto

última edición por Grandamakulo el Viernes, 10 Enero 2020, 09:04; editado 1 vez
Objetivo: Re: Uso De Oracle Java En Linux Mint
[quote user="Grandamakulo" post="47400"][align=justify]
tincho escribió:  
...El OAN es el Observatorio Astronómico Nacional. En su página de Efemérides —http://www.oan.es/servidorEfem/...me dice que necesito Java 1.6 mínimo...

Ok, si ahora es claro.
Muy bien, ingrese en la dirección que decís y efectivamente genera una pagina dinámica que muestra un montón de información. En firefox 71 funcionó
Si no tenés java instalado en tu sistema podes comprobarlo en la terminal con el comando:
java --version
Si te aparece algo como:
Citar:

openjdk 11.0.5 2019-10-15
OpenJDK Runtime Environment (build 11.0.5+10-post-Ubuntu-0ubuntu1.1)
OpenJDK 64-Bit Server VM (build 11.0.5+10-post-Ubuntu-0ubuntu1.1, mixed mode, sharing)

Eso indica que lo tenes instalado y el problema es otro.
Ahora si no te sale una info similar a esta, entonces tenes que instalarlo.
¿Que como se instalas?
sudo apt install default-jre
Con eso te debería funcionar la página web astronómica.
Referencia: https://www.digitalocean.com/commun...-con-apt-get-es
Saludos.

Perfil MP  
Objetivo: Re: Uso De Oracle Java En Linux Mint
Hola, @tincho:
Muchas gracias por tu respuesta. He seguido tus indicaciones con el siguiente resultado:

paco@paco-EasyNote:~$ java --version
Unrecognized option: --version
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.



Y:
paco@paco-EasyNote:~$ sudo apt install default-jre
[sudo] contraseña para paco:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
default-jre ya está en su versión más reciente (2:1.11-68ubuntu1~18.04.1).


¿Alguna idea?

PS.—Matizo:

paco@paco-EasyNote:~$ java -version
java version "1.8.0_201"
Java(TM) SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.201-b09, mixed mode)


Si está instalado, ¿por qué narices no soy capaz de usarlo en los —varios— navegadores?

última edición por Grandamakulo el Domingo, 12 Enero 2020, 11:17; editado 1 vez
Objetivo: Re: Uso De Oracle Java En Linux Mint
Ahora, creo que entiendo lo que estas tratando de hacer funcionar.
Intente correr el programa java "SIMULADOR DEL FIRMAMENTO Y SISTEMA SOLAR" y me pasa, creo, lo que a ti.
Pero si te fijas en la pagina de "error" da algunos consejos sobre como poder usar el programa. Una opción es descargándolo.
Al parecer los navegadores actuales ya no soportan java. Por lo que la solución es que traduzcan la aplicación java en el OAN a una API como tiene el AEMET.
http://www.aemet.es/es/datos_abiertos/AEMET_OpenData
O descargar el programa java a tu computadora y tratar de ejecutarlo localmente.
No se me ocurre nada mas, suerte.
Saludos.

Perfil MP  
Objetivo: Re: Uso De Oracle Java En Linux Mint
tincho escribió: [Ver mensaje]

O descargar el programa java a tu computadora y tratar de ejecutarlo localmente.
No se me ocurre nada mas, suerte.
Saludos.


Nada de nada.
En fin, una lástima. En cualquier caso, muchas gracias, Tincho

Objetivo: Re: Uso De Oracle Java En Linux Mint
Bueno, dejando de lado java existen varios programa de astronomía en Linux.
Echa un vistazo en:
https://www.linuxlinks.com/Astronomy/
Saludos.

Perfil MP  
Objetivo: Re: Uso De Oracle Java En Linux Mint
tincho escribió:  
Bueno, dejando de lado java existen varios programa de astronomía en Linux.
Echa un vistazo en:
https://www.linuxlinks.com/Astronomy/
Saludos.

Muchas gracias, tincho. La verdad es que los conozco casi todos y son, efectivamente, muy buenos. La lástima es no poder usar la aplicación del OAN.

En fin, como comentarios finales, creo que los mejores son Cartes du ciel —Skychart— en combinación con Moon Atlas y KStars que está hecho por los profesionales del observatorio de Yebes para su propio uso. Evidentemente, el resto tiene su público, ya que Celestia y Stelarium permiten orientarte directamente con el móvil sobre el cielo, por ejemplo, útil para quien todavía no se maneja a simple vista.

Un saludo, y reitero mi agradecimiento.


Página 1 de 1


  
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario

   

Está utilizando la versión (Lo-Fi). Para ver la versión completa del foro, haga clic aquí.

Powered by Icy Phoenix based on phpBB
Design by DiDiDaDo

Página generada en:: 0.0603s (PHP: 29% SQL: 71%)
Consultas SQL: 20 - Debug off - GZIP Activado