Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 2
Ir a la página 1, 2  Siguiente
 
Programilla Y Dudas
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Programilla Y Dudas 
 
Hola, llevo unas semanas con gambas 2 y he hecho mi primer proyecto, un pequeño programa para practicar las tablas de multiplicar. Espero usarlo con mis alumnos. Lo podéis descargar de http://losesteros.co.cc/joomla.

Quería que me confirmarais que la información que he puesto sobre los paquetes que hacen falta es correcta. En la lista de componentes usados aparecen gb, gb.form, y gb.qt, así que supongo que en derivados de Debian harán falta los paquetes gambas2-runtime, gambas2-gb-form y gambas2-gb-qt.

He probado a usar gb.gtk, pero no me funciona. Al principio tenía problemas con la gestión del teclado (salía un mensaje parecido a "No keyboard data event"), pero ahora me sale esto: "El programa se detuvo inesperadamente enviando la señal #11. Por favor, envíe un informe del problema a ." Me pasa tanto con la versión 2.0.0 como con la 2.8.

Saludos y gracias por vuestra atención.
Rodolfo.
 



 
rodoval - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
Hola.
Yo creo que sí son esos lo paquetes, pero quizá alguien podría confirmartelo mejor que yo. En cualquier caso podrías crear el paquete de instalación para que se descarguen los paquetes automáticamente.

Otra cosa. ¿No tiene la opción de hacer preguntas aleatoriamente? Creo que sería muy bueno. Si necesitas ayuda para hacerlo puedes pedirla aquí.
Saludos.
 



 
bies88 - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
Hola.

¿Que distribución de Linux usas?.
Las versiones de gambas que has usado están un poco desfasadas en el tiempo, trata con la 2.20.2.
Si no sabes instalarla por compilación, hay un script para hacerlo creado por el usuario jguardon.

http://gambas-es.org/viewtopic.php?f=6&t=441

Saludos
 



 
abarzuaf - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
Me sumo a la recomendación de que uses la versión más actual de gambas. El script de Jesús Guardón funciona de mil maravillas (aunque sólo fue probado para Ubuntu). Lo que hace el script es descargar el código fuente de gambas, chequear que se cumplan todas las dependencias y compilar: es tan fácil como instalar desde los repositorios.

Sin embargo, debes verificar que los potenciales usuarios del programa puedan disponer de las bibliotecas correspondientes, sino tendrías que distribuirlas junto con el programa.

Luego de actualizar gambas prueba tu programa cambiando gb.qt por gb.gui, así el runtime elegirá que componente usar según las bibliotecas gráficas que tenga instalado el usuario.
 




===================
Cómo programar con Gambas

Speed Books: informática libre.
 
fabianfv - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
Gracias por las rápidas respuestas, así da gusto.

Para el desarrollo he usado gambas 2.0.0 en Ubuntu 8.04. Es la versión que se instaló con apt-get. Mi objetivo esencial es que lo que haga funcione bien en los ultraportátiles de mis alumnos, que vienen con Guadalinex Edu (basado en Ubuntu 9.04) con gambas 2.8. No tienen opción de instalar paquetes, pero supongo que, al traer instalado gambas al completo no habrá problemas de que falten bibliotecas. No lo he probado mucho, pero parece que mi ejecutable va bien.

Si instalo en mi ordenador la última versión con el script que mencionáis, ¿puede que los ejecutables no funcionen bien con la 2.8? ¿Puedo instalar la nueva versión y conservar la antigua por si acaso? De momento, si uso gb.gui pasa lo mismo que con gb.gtk. Por cierto (antes no lo expliqué bien), el error se produce solo cuando se usa el teclado.

A biess88: Incluye la opción de preguntar las multiplicaciones de una mista "tabla" en orden aleatorio, pero no de mezclar varias tablas de una vez. Te tomo la palabra y ya me leerás en cuanto tenga alguna duda
 



 
rodoval - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
Citar:
Si instalo en mi ordenador la última versión con el script que mencionáis, ¿puede que los ejecutables no funcionen bien con la 2.8?


Es muy posible, ya que en la versión 2.20.2 se han corregido muchos errores que a lo mejor en el Runtime de la versión 2.8 no lo estaban.
 
Citar:
¿Puedo instalar la nueva versión y conservar la antigua por si acaso?


No se, nunca lo he probado, tener Gambas2 y Gambas3 no presenta problema porque se guardan en carpetas distintas, pero 2 versiones 2, habría que probar, o preguntar si otro forero lo ha realizado.

Citar:
De momento, si uso gb.gui pasa lo mismo que con gb.gtk. Por cierto (antes no lo expliqué bien), el error se produce solo cuando se usa el teclado.


Como te decía en el post anterior, muchos de esos errores son producto de la antiguedad de la versión. ¿Porque no te consigues otro equipo y pruebas instalando la versión 2.20.2 mediante el script?, o, desinstala la 2.8 de tu equipo he instala momentáneamente la 2.20.2 para realizar tus pruebas.

Saludos
 



 
última edición por abarzuaf el Jueves, 01 Abril 2010, 14:43; editado 2 veces 
abarzuaf - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
El problema es que los ordenadores donde se debe ejecutar el programa no son actualizables por los usuarios, viene con el software que a la Junta de Andalucía le ha parecido bien, y en principio, solo a la propia Junta le corresponde su gestión a través de la red. Así que actualizar ahí de gambas 2.8 a 2.20.2 es complicado (se puede hacer una petición de que lo hagan ellos, supongo).

Posiblemente intente instalar la versión nueva en otro portátil que tengo. Ya os contaré.

Rodolfo.
 



 
rodoval - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
Hola.

¿Porque no te bajas los fuentes de la version 2.8 y los compilas en tu maquina, para que tengas la misma versión que tus alumnos?.

Saludos.
 



 
abarzuaf - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
Citar:
¿Por qué no te bajas los fuentes de la version 2.8 y los compilas en tu maquina, para que tengas la misma versión que tus alumnos?


Es una buena idea, aunque lo único que he hecho hasta ahora funcionó igual.

He probado a instalar la versión 2.20 en el portátil. El script va perfectamente, lo hace todo solo. Pero el comportamiento de gambas con mi programa es el mismo: bien con gb.qt, error con gb.gtk o gb.gui: "El programa se detuvo inesperadamente enviando la señal #11". ¿Alguien tiene idea de lo que significa esto? El problema parece estar relacionado con la gestión del teclado.
 



 
rodoval - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Programilla Y Dudas 
 
hola espero lo que te voy a decir te sirva de algo .
antes que nada muy lindo el programa.

creo que es porque no tienes bien instalado el conjunto con la version lo que te dice alli que es un error. si ud tienes ubuntu intalado. podria ir a gestor de paquetes synaptic. y en buscar poner gambas alli le apareceran los paquetes de su version e instala o reinstala desde alli los paquetes faltantes. ya que ami me dio un error parecido e hice esto que le comento y si su version no es ubuntu. bueno alli no sabria que mas decir.

espero le sirva de algo. y felicitaciones por dedicarce a la enseñanza


atte: sergio /hostinglobal.net
 




===================
Atte: Sergio / HostinGlobal.Net
 
hostinglobal - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Dudas Con Textbox(solucionado) Dani26 Controles/Librerías/Componentes 4 Domingo, 13 Junio 2010, 21:54 Ver último mensaje
Dani26
No hay nuevos mensajes Dudas Sobre El Diseño.. CanihoJR General 6 Viernes, 26 Noviembre 2010, 17:14 Ver último mensaje
estrella_de_galicia
No hay nuevos mensajes Dudas Al Hacer Un Programa AGarcia General 25 Miercoles, 13 Julio 2011, 01:40 Ver último mensaje
razaAztk
No hay nuevos mensajes Dudas Con << Y >>, ~ jsbsan Javascript 6 Miercoles, 27 Abril 2016, 09:51 Ver último mensaje
Shell
 

Publicar nuevo tema  Responder al tema  Página 1 de 2
Ir a la página 1, 2  Siguiente

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario