Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Hace unos días me puse a actualizar el gambas via svn como lo he venido haciendo periódicamente, hago todos los pasos necesarios para recompilar y cuando ejecuto make me da el siguiente error:
Citar:
CPdfDocument.h:29:20: fatal error: PDFDoc.h: No such file or directory

El problema radica es que en Debian Wheezy cambió el paquete libpoppler-dev colocando allí lo que ellos consideran las librerías estables de poppler y crearon un nuevo paquete llamado libpoppler-private-dev donde colocaron lo que consideran las librerías inestables, que son precisamente las que el componente gb.pdf necesita para poder compilarse, así que solo en necesario instalar esta librería con el comando
aptitude install libpoppler-private-dev

Y vuelven a compilar su código. Espero que esto les sirva de ayuda.

[OT]
Que cómo descubrí lo de la nueva librería? gracias a un programita bastante chevere llamado apt-file que busca archivos dentro de los paquetes, luego de instalarlo hay que ejecutar
apt-file update

luego para buscar un archivo hay que ejecutar, por ejemplo en este caso
apt-file search PDFDoc.h

dando como salida
libpoppler-private-dev: /usr/include/poppler/PDFDoc.h

allí te dice el nombre del paquete y la ruta donde lo instalará
 




===================
William Cabrera
Mi Blog
Mi Twitter
IRC de Gambas en Español
 
willicab - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Gracias por el apunte, willicab.

Por cierto, ¿ya os habéis dado cuenta de que en Debian Wheezy ya no viene Gambas2?

Pronto dejará de estar disponible en las distros más importantes, lo digo para aquellos que se empeñan en aferrarse al pasado...


Saludos
 




===================
Jesús Guardón

Por favor, usemos el corrector ortográfico antes de pulsar el botón "Enviar".

"uo ǝs ʇɐu pıɟıɔıן ɐdɹǝupǝɹ ɐ dɹoƃɹɐɯɐɹ, soןo ɥɐʎ bnǝ dɹodouǝɹsǝןo"
 
jguardon - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Hola!.

¿ Entonces la 6.0.5 es la Wheezy ?

¿ Con la 6.0.4 Squeeze habéis podido compilar gambas 3.2 ?.
No paso de la 3.1.1 por cuestiones aparentemente de versión de alguna librería.

jguardon:

Compile desde fuentes directamente en la 6.0.4. Tener las 2 no es "pecado".    
Psss... si te digo que por curiosidad instale la 1.Pues dice la gamba que esta muy
disgustada contigo por que ya no te acuerdas de ella..

Es que no me diras que no tiene arte la mascota de Gambas1 comparada con la variante renderizada de la 2.
Mucho 3D, muy moderna.Pero la 1 mola mazo.

Cuestión básica.¿ Como se olvidaron de incluir la ayuda "no-online" en la 3 ?. Aunque sea obsoleta.
Cada versión tiene su lugar.
La 2 por que fue con la que empece.
La 2 por que tiene ayuda offline.
Por que no me disgusta su interfaz.
Por que puedo comparar como va en una versión u otra.

La 3 mejora en muchas cosas a la 2.
POO
Ayudas del editor
Ampliación de comandos.
Una interfaz mas atractiva. (A gusto del consumidor).
Soporte.
Y por que es el futuro hasta Gambas4.

Eso no quita que haya cosas en la 2 que les guste mas a unos u otros.

Saludos.
 




===================
Gambas Básico
"No es un bug, es una característica no documentada"
 
última edición por Shell el Jueves, 19 Julio 2012, 01:05; editado 1 vez 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Shell escribió: [Ver mensaje]
Hola!.

¿ Entonces la 6.0.5 es la Wheezy ?


No. Wheezy será la 7, supongo. 6.0.5 es sólo una actualización de Squeeze: http://www.debian.org/releases/

Citar:
Compile desde fuentes directamente en la 6.0.4. Tener las 2 no es "pecado".


Hombre, nadie ha dicho que lo sea... lo que pasa es que seguramente ya no se podrá instalar en Wheezy por la ausencia de paquetes antiguos que sean necesarios para Gambas2. Por ejemplo QT3, siendo esta la causa principal de que ya no venga Gambas2. Esto será extensible al resto de distribuciones en poco tiempo.

Qué sentido tiene emplear un sistema que ya no está soportado ni lo estará nunca más? Ningún usuario normal de tus programas escritos en Gambas2 va a perder tiempo en intentar compilar no se qué... Lo que quiere es que su programa funcione y ya está. Y cuando deje de funcionar y no tengas una alternativa antes, pues un cliente que pierdes.

Es cierto que hay cosas buenas y no tan buenas en ambas versiones, pero lo bueno se puede intentar llevar a la nueva versión y olvidarse de lo que ya nunca volverá. Estamos ahora en un tiempo de transición, donde todavía hay muchas dudas, algunas distros todavía no traen los paquetes de Gambas3 y tal, pero ya verás como en poco tiempo ya no habrá dudas... porque no habrá disyuntiva. Luego ocurrirá lo mismo con Gambas4 y la historia se repetirá.


Saludos
 




===================
Jesús Guardón

Por favor, usemos el corrector ortográfico antes de pulsar el botón "Enviar".

"uo ǝs ʇɐu pıɟıɔıן ɐdɹǝupǝɹ ɐ dɹoƃɹɐɯɐɹ, soןo ɥɐʎ bnǝ dɹodouǝɹsǝןo"
 
jguardon - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
"Shell escribió: 
Compile desde fuentes directamente en la 6.0.4. Tener las 2 no es "pecado".


jguardon escribió: 


Hombre, nadie ha dicho que lo sea... lo que pasa es que seguramente ya no se podrá instalar en Wheezy por la ausencia de paquetes antiguos que sean necesarios para Gambas2. Por ejemplo QT3, siendo esta la causa principal de que ya no venga Gambas2. Esto será extensible al resto de distribuciones en poco tiempo.



¿ Entonces vamos  a tener todos los Linux en plan Unity y escritorios parecidos ?.  
Repaso y mejor esto lo pregunto en otro post.

Mientras las actualizaciones vayan a mejor.Por un lado es un poco absurdo de que muchas pero muchas aplicaciones dejen de funcionar.
Es un cambio muy radical.De ahí lo de tener QT3 y QT4 en una distro, aun.

jguardon escribió: 

Qué sentido tiene emplear un sistema que ya no está soportado ni lo estará nunca más? Ningún usuario normal de tus programas escritos en Gambas2 va a perder tiempo en intentar compilar no se qué... Lo que quiere es que su programa funcione y ya está. Y cuando deje de funcionar y no tengas una alternativa antes, pues un cliente que pierdes.


Naturalmente para el profesional no hay otra alternativa que actualizarse.Y para el usuario ídem de lo mismo si quiere que funcione la aplicación.

jguardon escribió: 

Es cierto que hay cosas buenas y no tan buenas en ambas versiones, pero lo bueno se puede intentar llevar a la nueva versión y olvidarse de lo que ya nunca volverá. Estamos ahora en un tiempo de transición, donde todavía hay muchas dudas, algunas distros todavía no traen los paquetes de Gambas3 y tal, pero ya verás como en poco tiempo ya no habrá dudas... porque no habrá disyuntiva. Luego ocurrirá lo mismo con Gambas4 y la historia se repetirá.


Si no sacan al poco QT5.

Como no soy profesional, ando siempre haciendo cosas entre una versión y otra.Lo que realmente complicado es los profesionales que tengan sus programa en Gambas2
y tengan que actualizarse a Gambas3.Con el tiempo y el dinero que significa eso.  

Muy complicada veo la vida de un programador que se gana la vida programando.Tantas constantes actualizaciones.
Lo que luego implica como explicar al cliente todo estos cambios. Ellos también tienen que renovarse.Que a muchos
habrá que dárselo todo mascado.(Que funcione y listo y si puede que sea a la primera).

Saludos.
 




===================
Gambas Básico
"No es un bug, es una característica no documentada"
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Shell:

Citar:
¿ Como se olvidaron de incluir la ayuda "no-online" en la 3 ?. Aunque sea obsoleta.


Lei que la ayuda de gambas3 eran aproximadamente 300 mb... a lo mejor no es un olvido, es un problema de servidores de descarga y si realmente quieres tener una ayuda "obsoleta", ya la ayuda de gambas se va "rehaciendo" y añadiendo cada dia...

Saludos
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Julio:

El problema es que en casa no dispongo de Internet.Resultara raro.Herejiaaaa!.
Ejem..si en casa tuviera Internet, no estudiaría.

Al final solucione el problema del "pincho" de Vodafone y me conecto poco..tres veces...
Son las veces "gratis".   

Lo justo para actualizar el sistema.

Pagar 2€ por cada vez que te conectas con el "pincho" me parece de juzgado de guardia.
Y pagar dos veces a estos vampiros, paso.

Al precio que están y el tiempo que le dedico, no me merece la pena.
¿ Como puede pesar tanto ?. Sera que trae todos los idiomas.

Creo que tengo parte de la ayuda  en el disco,  tengo que buscarlo.

Saludos.
 




===================
Gambas Básico
"No es un bug, es una característica no documentada"
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Shell escribió: [Ver mensaje]

Si no sacan al poco QT5.


QT5 se lanza oficialmente en septiembre: http://qt-project.org/wiki/Qt-5

Ya ves, esto no hay quien lo pare, por eso lo de renovarse o morir. Así que viendo este panorama, ¿de verdad crees que Qt3 tiene algo de futuro? ¿Y gambas2 que depende de Qt3?

Yo no.

Saludos
 




===================
Jesús Guardón

Por favor, usemos el corrector ortográfico antes de pulsar el botón "Enviar".

"uo ǝs ʇɐu pıɟıɔıן ɐdɹǝupǝɹ ɐ dɹoƃɹɐɯɐɹ, soןo ɥɐʎ bnǝ dɹodouǝɹsǝןo"
 
jguardon - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Problema Para Compilar Gambas3 En Debian Wheezy Y Como Solucionarlo 
 
Mira vale que se ha movido este hilo

Pienso igual que jguardon acerca de que en este mundo lo que nos queda es la nostalgia por el pasado, pero no podemos aferrarnos a eso porque corremos el riesgo de quedar atrás, creo que el tiempo de gambas 2 ya está terminando y lo que queda es ir pasando a la nueva versión, no es el único caso, por ejemplo ya python va para su versión 3, pero aun puedes encontrar librerías de la versión 2.3, la tecnología cambia muy rápido y toca adaptarse a ella o desaparecer
 




===================
William Cabrera
Mi Blog
Mi Twitter
IRC de Gambas en Español
 
willicab - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Compilar Gb.media En Debian Wheezy Shell Controles/Librerías/Componentes 1 Domingo, 14 Octobre 2012, 10:32 Ver último mensaje
Shell
No hay nuevos mensajes Habra Algun Repositorio De Gambas 3.5 Para... jousseph Instalación 10 Domingo, 16 Marzo 2014, 18:53 Ver último mensaje
jousseph
No hay nuevos mensajes Como Instalar Gambas3 En Debian 9? v3ctor General 11 Martes, 04 Julio 2017, 18:47 Ver último mensaje
tincho
No hay nuevos mensajes Repositorio De Gambas3 Para Debian Sequeeze sebikul Instalación 1 Lunes, 26 Noviembre 2012, 09:46 Ver último mensaje
Shell
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 0 invitados
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario