Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
Pregunta Sobre La Compatibilidad
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje Pregunta Sobre La Compatibilidad 
 
Buenos dias, tengo una pregunta sobre la compatibilidad de gambas3, tengo la version 3.8.4, en la cual cree una base de datos,  mañana tengo que mostar esta base en la universidad donde la computadoras tienen instalada la 3.5.4 tendre problema de comaptibilidad? Se si como puedo resolver?
 



 
última edición por Franz94 el Lunes, 01 Febrero 2016, 02:07; editado 2 veces 
Franz94 - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Pregunta Sobre La Compatibilidad 
 
Hola,
Creo haber leído que existen unos problemas con BD en SQLite. Lo otro es que tengas controles que no te los reconozca... y creo que si llevas el proyecto listo no te lo reconocerá.  Hace un tiempo estuve desarrollando una cosa poca en gambas 3.8.4 (mientras otros llenan Sudokus yo programo    ) ... y cuando me llevé el proyecto a otro computador me avisó que estaba en una versión distinta y... lo siguiente no recuerdo, quizá: 1) me mostró las clases pero no podía ejecutarlas o 2) no me mostró nada.
Actualicé y listo pude seguir viendo el proyecto...

¿y si te creas una máquina virtual y en ella muestras el proyecto con la versión de gambas que desarrollaste?

Saludos...
 



 
vicr - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Pregunta Sobre La Compatibilidad 
 
Franz94:

Normalmente la versión más antigua avisa de que la aplicación esta hecha con una versión más actual.
Supongo que con un paquete de instalación si dará mas problemas. Si llevas el código fuente,
prueba la opción "Compilar todo" del menú de proyectos y ejecutalo.

En cuanto a problemas con SQlite3, no recuerdo si nuestro experto Shordi nos ha comentado algo.

Por cierto, cuando tengas un momento de lugar. Podías contarnos un poco del uso del lenguaje gambas en tu universidad.
¿ Hacéis  un curso ?.
¿ Es un proyecto y lo puedes hacer en el lenguaje que quieras ?.

Si sabes que en tu lugar de trabajo usan Gambas3.5 puedes:
- Actualizar las máquinas del trabajo..jeje.
- Crearte una máquina virtual en casa y que tenga gambas 3.5. Puedes transferir fácilmente archivos de la maquina física a la virtual. Compartiendo un directorio.

De todas formas siempre tienes la opción de Compilar todo del menú de proyectos de Gambas.

Saludos
 




===================
Gambas Básico
“Si no puedes explicar algo de forma sencilla, entonces es que tú no lo entiendes bien.” Albert Einstein
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Pregunta Sobre La Compatibilidad 
 
Yo  no he tenido ningún problema trabajando con SQLite en las nuevas o viejas versiones.

Sigue el consejo de Shell: No lo lleves compilado. Recompila en la máquina que tiene 3.5 y te debería funcionar todo... salvo excepciones.
 




===================
No podemos regresar
 
shordi - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Pregunta Sobre La Compatibilidad 
 
Shordi:

Citar:
y te debería funcionar todo... salvo excepciones.

Yo he tenido problemas con los formularios, en concreto con el tema de los menus.

Lo suyo es siempre trabajar con la que tenga el resto de la gente con la que vayas a compartir el programa o hacer la presentación, asi te quitas de problemas.

Saludos
 




===================
Blog personal
Web: SoloGambas seleccion de articulos dedicados a Gambas
Visita el Curso de Gambas3 ¡¡¡Gratuito!!!
 
jsbsan - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: Pregunta Sobre La Compatibilidad 
 
Yo me refería a componentes que se han reescrito por completo, como el smtp , el IDE, etc... no he notado nada en los menús.
 




===================
No podemos regresar
 
shordi - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
Ocultar¡Este tema fue útil?

 

Elegir valoración:                       

Media de valoración Valoración mínima Valoración máxima Número de valoraciones
0.00 0 0 0
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Pregunta Sobre Código aaRon General 3 Viernes, 26 Marzo 2010, 17:50 Ver último mensaje
jguardon
No hay nuevos mensajes Gambas Compatibilidad acero General 2 Jueves, 16 Junio 2011, 19:46 Ver último mensaje
acero
No hay nuevos mensajes Pregunta Sobre Expresiones Regulares Regexp dquinter General 1 Jueves, 26 Abril 2012, 20:21 Ver último mensaje
shordi
No hay nuevos mensajes Una Pregunta Sobre La Lista De Correos De ... shordi General 3 Martes, 01 Abril 2014, 10:16 Ver último mensaje
shordi
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
No puede descargar archivos
No puede publicar eventos en el calendario