Comunidad Gambas-es
Problema con programas en 14.04 - Versión para impresión

+- Comunidad Gambas-es (https://gambas-es.org)
+-- Foro: Gambas (https://gambas-es.org/forumdisplay.php?fid=3)
+--- Foro: Instalación (https://gambas-es.org/forumdisplay.php?fid=5)
+--- Tema: Problema con programas en 14.04 (/showthread.php?tid=1030)

Páginas: 1 2


Problema con programas en 14.04 - portaro - 15-09-2022

Tengo un pc con Flavitu Linux que tiene base Ubuntu 14.04.

Algunos programas de gambas note ahora que no se inician bien ni tampoco me aparecen listados como instalados en Gambas IDE software installed.

Por ejemplo el generador de carnets, constructor de diplomas, creador de orlas todos me dan problemas de interfaz dejo el screen de un error →

[Imagen: bb4.png]

La version de Gambas que tengo instalada es 3.17.13 creo que es tema que se me actualizo a esta version el gambas y ahora esos programas como eran de otra version se quedaron estropeados.

Alguna sugerencia?


RE: Problema con programas en 14.04 - tincho - 15-09-2022

(15-09-2022, 16:42)portaro escribió:  Alguna sugerencia?

Cambia el componente gb.qt4, gb.qt5 o gb.qt por gb.gui


RE: Problema con programas en 14.04 - Shordi - 15-09-2022

Recompila esos programas en ese ordenador. Así te aseguras de que todo esté adecuado.

Saludos.


RE: Problema con programas en 14.04 - Shell - 15-09-2022

Portaro, ¿ hablaste de tu distro en el foro ?. ¿ Cómo que M$ Excel o Word ?. Wink
 
(15-09-2022, 17:10)tincho escribió:  Cambia el componente gb.qt4, gb.qt5 o gb.qt por gb.gui

Probablemente cuando use algunas de esas opciones y active perfilado para depuración le de error.
Pero eso es otra historia, que tiene solución temporal.
 
(15-09-2022, 18:37)Shordi escribió:  Recompila esos programas en ese ordenador. Así te aseguras de que todo esté adecuado.

Muchos de los programas que tienen un tiempo y probamos de los compañeros tienen el componente activo,
a lo más de gb.qt4 (algunos gb.gui si vamos muy atrás) y luego se queja el editor, pero se solucionaba con
activando gb.gui.qt

Estuve viendo otras opciones del editor, en el menú de proyecto existe la opción "Limpiar".
Es como si dejase limpio el proyecto, eliminando copias de seguridad o archivos generados.
Esto supongo que lo conocéis.

La dos opciones, tanto la de Tincho como la de Shordi, son muy validas.
A ver que nos cuentas. Smile

Saludos


RE: Problema con programas en 14.04 - portaro - 20-09-2022

Pues llevo un lio de mil pares con el computador.

Y no es tema de Gambas es que es tan viejo que el problema de entrarme el update de Gambas IDE me hace que no me de para tener los programas antiguos como los tenia siempre me a esos errores.

Intente buscar los programas en el farm de gambas y nada no me salen, no me eja siquiera poner texto en los campos - tags y filter.

Entonces intente buscar los programas en web como ejemplo en enlace 1 el creador de orlas - son todos del amigo jsbsan y el los tiene en web :

Enlace 1

Enlace con varios programas instalables

Ahora os cuento haga lo que haga o sea si instalo el .deb o si me descargo y recopilo el programa al final el error es el mismo, yo creo que or la version del mismo IDE.

Problema aqui que este pc esta funcionando tan bien que no quiero formatearlo.
Pero tampoco tengo espacio para poner el otro pc que solia estar ally pero ahor no puede por espacio, o sea tengo esos programas en otros pcs y no es un tema problematico pero esos programas y los programas de jsbsan siempre intento tenerlos conmigo.

No se que hacer porque creo que tendria que downgradear el Gambas.


RE: Problema con programas en 14.04 - tincho - 20-09-2022

Insisto, tienes que cambiar qt4 por qt5.
[Imagen: H3VNgZm.png]
Luego, para probar el programa orlas, tube que deshabilitar la línea 24 de fmain "ModuleUpdate.comprobar..."  y por si acaso borre por completo el modulo ModuleUpdate luego arranco pero un cartel idicaba que tenia que instalar otros programas mas.
[Imagen: e3LRsiy.png]
Pero el programa arranco.

Como nota final, tienes que saber que todo programa que tengo entre sus componentes gb.qt4 seguramente no funcionen y debes actualizar el código fuente para que funcione en las nuevas versiones del interptrete gambas.
Luego los programas deben estar hechos, dentro de lo posible, con los componentes gb.gui ya que de est amanera aumenta la compatibilidad en diferentes escritorios.

(15-09-2022, 16:42)portaro escribió:  Tengo un pc con Flavitu Linux que tiene base Ubuntu 14.04.

Cuentanos sobre esta distro tan vieja y por que usasas.


RE: Problema con programas en 14.04 - portaro - 20-09-2022

Intentare hacer lo que me dices o sea editar los programas aqui en el Flavitu y ponerle los componentes correctos que me sugieres.

La distro esta la hice yo y un chico Español llamado Miguel Angel era una derivacion de Ubuntu con pretenciones de reunir usuarios del Norte de Portugal y Galicia en especial aunque tenia el interes de dos Universidades Españolas una de Madrid y la otra ya no se de que región era.

El tema es que estaba dado el proyecto a la participacion conjunta bajo el proyecto de cooperacion transfronteriza de la Euroregión Chaves-Verín.
Pasa que no nos dieron respuesta y entonces el proyecto no salio adelante.
Y esa es la Historia de Flavitu, en este pc fue sobreviviendo y aún anda por aqui y la verdad va muy bien.

En los dos enlaces podreis saber más de Flavitu :
https://wiki.ubuntu.com/DerivativeTeam/Derivatives/Flavitu-Linux

https://www.poctep.eu/pt-pt/node/3045

Como es obvio Flavitu traia programas de Gambas y el IDE integrado, ya que usaba algunos programas hechos en este IDE, ademas recuerdo que jsbsan contribuió con programas y siempre me ayudo mucho.

Asi que dejo un palabra de gracias por sus colaboraciones tanto a jsbsan como a Miguel Angel.

Los iconos de M$ Excel o Word, es porque de la escuela los niños traen muchos trabajos en ese formato como el pc es de uso escolar los porgramas estan en Wine via Playonlinux.


RE: Problema con programas en 14.04 - tercoide - 20-09-2022

yo diria que tienes que actualizar Ubuntu ...


RE: Problema con programas en 14.04 - tincho - 20-09-2022

(20-09-2022, 14:55)portaro escribió:  Intentare hacer lo que me dices o sea editar los programas aqui en el Flavitu y ponerle los componentes correctos que me sugieres.
Tal vez co eso lo soluciones.
 
(20-09-2022, 14:55)portaro escribió:  La distro esta la hice yo y un chico Español llamado Miguel Angel era una derivacion de Ubuntu con pretenciones de reunir usuarios del Norte de Portugal y Galicia en especial aunque tenia el interes de dos Universidades Españolas una de Madrid y la otra ya no se de que región era.
Coincido con Tercoide y te aconsejo que actualices el sistema y uses una distro estandar como xubuntu o manjaro ambas son livianas usan el escritorio XFCE y esteticamente estan bien logradas, y luego le agregues los paquetes de gambas (luego de actualizarlos).
Te felicito por hacer una distro, ya que es una ardua tarea, sobretodo mantenerla. Pero sin una comunidad de usuarios y programadores detras no es viable en el tiempo y tal vez es mejor usar una existente, como mencione antes, y adaptar algunas cosas.
Con unos script Bash puedes hacer maravillas.
(20-09-2022, 14:55)portaro escribió:  Asi que dejo un palabra de gracias por sus colaboraciones tanto a jsbsan como a Miguel Angel.
A Miguel no lo conozco ¿Tal vez sea alguien del foro? pero a Julio si y tambien le agradezco sus videos y todo el código que viene compartiendo con todos desde hace muchs años ya.
(20-09-2022, 14:55)portaro escribió:  Los iconos de M$ Excel o Word, es porque de la escuela los niños traen muchos trabajos en ese formato como el pc es de uso escolar los porgramas estan en Wine via Playonlinux.
Hoy en dia eso no tiene ningun sentido, porque tanto Gnumeric como Calc ofrecen total compatibilidad con los formatos .xls y .xlsx


RE: Problema con programas en 14.04 - Shordi - 20-09-2022

Cita:Coincido con Tercoide y te aconsejo que actualices el sistema y uses una distro estandar como xubuntu o manjaro ambas son livianas usan el escritorio XFCE y esteticamente estan bien logradas, y luego le agregues los paquetes de gambas (luego de actualizarlos).
No olvides Ubuntu Budgie. ·Es una de las más livianas... al menos la Raspberry ni pestañea cuando la maneja...

Saludos.