Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 1 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Soprano, nueva versión.

En una nueva instalación de Soprano, recién
bajado del repositorio, encuentro este error luego de crear un nuevo proyecto y hacer click en el ojo de "El tema":

[Imagen: U8RVerK.png]
[Imagen: mQFM5An.png]
Nótese también que el label de "Fecha de inicio" esta truncado

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!


  1. Al eliminar un tema, en el gestor de temas, en el «combo» de temas, se repite la lista, como si la cargase de nuevo sobre la que existe.
  2. En «propiedades del proyecto», el nombre del proyecto no admite el carácter "_" —creo que es por el IsAlnum()—, pero al darle de alta sí se permite. Como en «propiedades» no se puede cambiar el nombre, si quieres modificar las propiedades, tienes que borrar el proyecto y hacer uno nuevo, ya que sale el error de «no es un número o letra» constantemente.

En un lugar de La Mancha de cuyo nombre me acuerdo perfectamente...
    ¡Gracias!

Oído cocina. Me pongo a ello ya mismo, que quedan poquitos días para el pistoletazo de inicio.

Gracias.

Todo arreglado (creo, espero, ruego, confío, pido a los cielos).
Ya me cuentas.


Saludos

No podemos regresar
    ¡Gracias!

Grandamakulo:

Esta mañana al abrir un proyecto que no tenía contenido en "Esctructura" y sí en "Adjuntos" me ha generado un error de que "no existe el fichero" pero, tonto de mí, he olvidado la línea después de dar a "ignorar". Luego no mostraba de entrada la estructura de carpetas de "Adjuntos"... y luego funcionaba perfectamente.
No he podido duplicar el error después de eso. Si te pasa en algún momento y consigues aislarlo, a al menos el dichoso número de línea, dímelo, que odio tener bugs incontrolados.

Saludos.

No podemos regresar
[-] Los siguientes 1 usuarios dice gracias a Shordi por este post:
  • Grandamakulo
    ¡Gracias!

Hola, Shordi, hay un problemilla en «Scena.class» en la línea 200. Cuando intenta hacer un backup dice que no encuentra la ruta. Y es urgentillo; me bloquea en plena escritura  Big Grin .

En un lugar de La Mancha de cuyo nombre me acuerdo perfectamente...
    ¡Gracias!

Bug report
Al intentar crear un nuevo proyecto da error
[Imagen: RwPzoPd.png]
Puse Nombre: "Recetas de cocina" y también "recetas_de_cocina" pero da un error diciendo que solo se permiten letras o números. Bien luego puse el nombre sin espacios ni "_" ni "-" y ahi si que funciono.
¿Esto de no permitir los espacios ni _ o - a que se debe exactamente ?
Saludos.

1 Saludo.
    ¡Gracias!

(01-11-2021, 18:49)Grandamakulo escribió:  Hola, Shordi, hay un problemilla en «Scena.class» en la línea 200. Cuando intenta hacer un backup dice que no encuentra la ruta. Y es urgentillo; me bloquea en plena escritura  Big Grin .

Ahí intenta grabar el texto que lleves tecleado en

GAMBAS
  1. m.Preferences["Preferences/path_backups"] &/ File.Name(m.project) &/ ("Texts") &/ File.Name($file) & "_" & Format(Now, "yyyy-mm-dd hh:nn:ss")



En mi caso el Preferences/path_backups es /home/jorge/soprano/Copias
si el proyecto se llama "miproyecto" debiera existir la carpeta "miproyecto" dentro de Copias y la carpeta "Textos" dentro de miproyecto es decir sería la carpeta:

/home/jorge/soprano/Copias/miproyecto/Textos/

allí se graba un fichero con el título de la escena más la fecha y la hora como nombre, algo así:

   1.-Escena 1_2021-11-01 12:05:37

Revisa en el menú Herramientas->Preferencias qué carpeta figura como carpeta de copias de seguridad y dentro de ella deberían haber dos carpetas "Copias" y "Textos"

Si todo es correcto y todas las carpetas existen... dímelo que es un enano crecido de esos.

Saludos.

Cita:¿Esto de no permitir los espacios ni _ o - a que se debe exactamente ?
Al tema de las ordenaciones en las listas de carpetas y de las compresiones en las copias de seguridad (creo recordar). Al permitir caracteres "extraños" había problemas que ahora mismo no recuerdo muy bien (esto viene de muy atrás).
Creo recordar que al propio gambas le pasa lo mismo y no permite espacios ni demás en el nombre de los proyectos.


Saludos

No podemos regresar
    ¡Gracias!

(01-11-2021, 20:05)Shordi escribió:  En mi caso el Preferences/path_backups es /home/jorge/soprano/Copias
si el proyecto se llama "miproyecto" debiera existir la carpeta "miproyecto" dentro de Copias y la carpeta "Textos" dentro de miproyecto es decir sería la carpeta:

/home/jorge/soprano/Copias/miproyecto/Textos/

allí se graba un fichero con el título de la escena más la fecha y la hora como nombre, algo así:

   1.-Escena 1_2021-11-01 12:05:37

Pues todo bien hasta lo de la ruta, pero esa carpeta está vacía.

/home/paco/soprano-main/Copias

Ésa es, además, la ruta que aparece en preferencias.
Y sigue saliendo el error.
 
[Imagen: 2021-11-02-10-20.png]

En un lugar de La Mancha de cuyo nombre me acuerdo perfectamente...
    ¡Gracias!

Ok. No sé qué puede haber pasado para que esas carpetas no existan, que se supone que se crean en el momento de crear el proyecto, tal vez sea un proyecto creado en una versión antigua o un duende de la informática, pero bueno, a grandes males grandes remedios:

He cambiado la "responsabilidad" de crear la estructura de carpetas de cada proyecto al momento de abrirlo y no al momento de crearlo. Es decir, que abres un proyecto, creado con la versión de soprano que sea, y se comprueba la existencia de todas las carpetas del proyecto creando las que no existan. Con eso debería ser suficiente para que no sufras más ese error.

Actualizado al gitlab está. Versión 2.1.8

Pido perdón por los trastornos causados.

Saludos

No podemos regresar
[-] Los siguientes 1 usuarios dice gracias a Shordi por este post:
  • Grandamakulo
    ¡Gracias!


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)