Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Fallo al actualizar
#1

Buenas!.

Creo en este equipo no llegué a actualizar la Gambas3 cuando tuvimos el último problema "gordo" que no iba Gambas3 como debiese al actualizar,
( la actualización apresurada).

Este error no lo había visto nunca. Debe ser la última actualización que tiene Gambas.

[Imagen: fmz25XA.png]

A ver esta vez:

[Imagen: yhRneDe.png]

Ahora paquetes rotos. Dos.
El instalador ha tirado "palante" sin pensárselo...miro Synaptic...no hay paquetes rotos y ha funcionado con normalidad.

No, no es normal.

[Imagen: koJ94T1.png]

Y parpadea el texto. Es la estable. Parpadeo exagerado.
Linux Mint 19.3

Saludos

Esto no se solía ver antes.

[Imagen: LEbu81U.png]

Según eso, ¿ compatible X11 y Gnome3 ?....

Pero no dice nada de Qt. Blush

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!
#2

Desinstala todo y reinstala. Yo uso linux mint 20 y va perfecto.

No podemos regresar
    ¡Gracias!
#3

(20-07-2021, 20:33)Shordi escribió:  Desinstala todo y reinstala. Yo uso linux mint 20 y va perfecto.

Cierto , tengo también la 20.1 y no lo hace, es la  Linux Mint 19.3 (Ubuntu Bionic). Hasta configurando y compilando desde fuente me ha dado el mismo problema.
Eso de desinstalar e instalar, me recuerda a otro sistema.  Rolleyes

Uno de los problemas que observo si queremos configurar e instalar desde fuente,  por ejemplo usando las dependencias de la Ubuntu 18.04 (Bionic).
Vemos una parte para instalar las dependencias, una línea de instrucción que comienza así:

Bash
  1. apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install....



¿ Esa línea es correcta ?.  Se puedo poner un "sudo" al principio del primer apt-get, pero el siguiente debería también llevarlo.
A menos que sea:

Bash
  1. apt-get update && DEBIAN_FRONTEND=noninteractive && apt-get install....



Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!
#4

Nu sé Sad Sad  Yo siempre uso el repositorio estable...

No podemos regresar
    ¡Gracias!
#5

Cita:Se puedo poner un "sudo" al principio del primer apt-get, pero el siguiente debería también llevarlo.
Shell, siempre que uses apt-get tienes que poner sudo, a menos que seas root.
Saludos.
    ¡Gracias!
#6

(21-07-2021, 11:33)tincho escribió:  Shell, siempre que uses apt-get tienes que poner sudo, a menos que seas root.

Entonces se da por entendido que en el segundo apt-get se debe poner sudo.
Con solo uno, daba el error como cuando tienes abierto Synaptic y usas en una linea de comando apt-get.

No sé si es que de la época de la gambas 3.16 la línea de comandos de las dependencias parece haber cambiado.
Por ejemplo, que no se muestre el proceso de configuración paso a paso, solo mostrando cuando hay un error, al igual
que si un componente está deshabilitado. Eso tanto en el ./reconf-all como el ./configure

Por defecto yo estaba poniendo solo un sudo al comienzo ya que no había otro apt-get, cosa que ahora si ha cambiado.
Al igual que se ha incluido la línea para detección del sistema y configuración de los paquetes con:

Bash
  1. ./configure -C -q



Cuando yo solamente usaba:

Bash
  1. ./configure



En otras aplicaciones lo he visto igual que la primera forma del configure con -C -q.
A lo mejor en breve tiempo ha cambiado la sintaxis y mejorado.

Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!
#7

Cita:Con solo uno, daba el error como cuando tienes abierto Synaptic y usas en una linea de comando apt-get.
Eso es otro tema. Si estás usando synaptic los ficheros de paquetería se bloquean y apt-get no puede acceder a ellos.

Saludos

No podemos regresar
    ¡Gracias!
#8

(21-07-2021, 14:04)Shordi escribió:  Eso es otro tema. Si estás usando synaptic los ficheros de paquetería se bloquean y apt-get no puede acceder a ellos.

Pues ese es el mismo efecto que hace la línea de instalación de las dependencias si solamente usas un sudo al principio de la instrucción,
que fue lo que me pasó. Ya que no esperaba otro apt-get después. Digamos que con el primer sudo al comienzo de línea
entendí que estaba usando la instrucción de principio a fin como administrador, incluido el apt-get install. Se bloqueaba
los ficheros de paquetería.

En parte es una forma de abreviar y hacer todo en la misma línea, actualizar paquetes, instalar paquetes.
Solo que si te acostumbras a hacerlo de una manera, pues puedes pensar que al comienzo con un "sudo" era suficiente.
De ahí el cambio que se ha añadido ahora en la instalación de las dependencias, que si no te fijas bien en ese detalle,
no va a funcionar.

Tu ves esto:

Bash
  1. apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y ....



Y dices, pues añado solo un sudo al principio. Error.
En este caso dos instrucciones que necesitaban usarse como administrador.

Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje
Último mensaje por ahtonio
21-04-2021, 20:48

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)