Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Linux se pone lento...
#1

Pues tengo Ubuntu 20.04 LTS, Linux Mint 20.2 y Mageia 7, en multi-arranque en la PC con 6 GB de RAM, AMD Athlon II.

Casi siempre, luego de hacer algo productivo, me pongo a ver/escuchar vídeos de youtube, pero al mismo tiempo ejecuto Quadrapassel (Tetris), para estar haciendo algo adicional. Tan pronto se interrumpe el vídeo para dar paso a un molesto comercial, se pone lento el apuntador del mouse, con el que tengo que girar las piezas del Tetris para que encajen. Tan lento se pone, que pierdo el ritmo y pierdo la partida.

Y eso pasa en las 3 distros mencionadas.

Lo importante aquí no es perder en el Tetris, sino la lentitud de la PC + Linux al aparecer los comerciales en el vídeo. Tan pronto corto el comercial y prosigue el vídeo, nuevamente la PC + Linux regresan a su actividad normal.

Será posible que dichos comerciales sean códigos javascripts que ocupan demasiado procesamiento? Ésto ultimo lo digo porque recién instalé React y con el simple ejemplo que trae al instalarse, ya el giro del Ariel (Logo) causa lentitud.

Pronto abrí Monitor del Sistema y lo dejé corriendo. Con el vídeo y el Tetris en curso, cpu1 está en 31% y cpu2 en 29% aproximadamente. Y aparece un comercial: Ahora cpu1 está a 92% y cpu2 a 100%. La gráfica de uso de cpu del Monitor de Sistema está "a tope".

Hay ciertos detalles que Liinux ha de resolver, porque (---me muerdo la lengua---) en "Ventanas" no ocurre eso.

Y como he dicho en ocasiones anteriores, aquí estoy usando Linux y sus diferentes distribuciones, porque tengo confianza en que algún día será uno de los mejores sistemas operativos.

Saludos.

Es mejor saber un poco de todo, que todo de muy poco. Lo primero, garantiza la supervivencia humana.
    ¡Gracias!
#2

Creo que efectivamente algunas cosas en Linux requieren algo de atención por parte de los desarrolladores, eso es indiscutible.

Pero hay que entender que las cosas evolucionan rápidamente y donde antes un PC con doble núcleo como el tuyo, que tiene más de 10 años era suficiente, ahora ya no lo es. En el caso que describes, probablemente eso suceda porque tu tarjeta gráfica no está funcionando bien o no tiene los drivers activados para manejar la aceleración gráfica y por consiguiente, ese "esfuerzo" lo tiene que hacer la CPU, en lugar de la GPU. Puede que el navegador no tenga activada esa aceleración gráfica o qué se yo, pero hoy en día con los elementos modernos que componen un PC, sobre todo las tarjetas gráficas más o menos decentes, eso no debería ocurrir para nada.

A veces echamos la culpa de los fallos al núcleo de Linux (ya que te pasa en tres distros distintas) cuando en realidad podría ser por incapacidad del hardware (no es tu caso, ya que parece que funciona en W$) o por alguna mala configuración, que parece lo más probable en este caso.

Investiga qué chipset lleva tu gráfica (si es que tienes GPU dedicada) y busca cómo instalar los controladores para la misma, es lo único que puedo aconsejarte ahora mismo como solución más probable...


Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#3

Por otro lado, yo no veo nunca ningún anuncio de youtube por medio de instalar los plugins de Firefox  adblock y el adblocker Ultimate. A lo mejor con eso solucionas el problema.

Saludos.

No podemos regresar
    ¡Gracias!
#4

Me pasa, y mi PC es bastante rapida: i5 + Geforce 920m + 8GB

El culpable suele ser Firefox ,que me consume toda la RAM, o los scripts de Thunderbird. Luego, empieza a usarse el Swap y ahi se freeza todo.

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#5

No estoy de acuerdo en la afirmación "Linux es lento". Existen algunos programas que sí son lentos pero no creo que tenga relación directa con el SO.
Dejo unas capturas de pantalla del consumo de RAM en mi GNU/Linux, en una de ellas se ve el uso de recursos con Gambas IDE + Firefox + foro de gambas, luego lo mismo mas la visualización de un video den youtube.
[Imagen: e5RTarQ.png]
[Imagen: rsnFUUn.png]
Luego si logro hacer un hueco de tiempo hago unas pruebas en una cp vieja a ver que resultados arroja.

Saludos.
    ¡Gracias!
#6

Yo no se que le pasa a esta PC. Firefox, Thunderbird, un par de Archivos y nada mas.... Miren la swap!!!

[Imagen: xorWIq4.png]

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#7

Estas son las capturas de mi sistema usando Youtube en el momento preciso de un anuncio publicitario y luego del video sin anuncios:

[Imagen: gFfJuWu.png]

[Imagen: 0ZOUIft.png]


Si bien es cierto que un anuncio a pantalla completa (del marco del vídeo) consume algo más de CPU, seguramente por el número de FPS o por la resolución, trabajando en mi caso con dos monitores (a la izquierda LG de 27" a 2K y a la derecha un Benq de 24" a 1080p) no observo consumos excesivos de RAM ni de CPU. Como digo, esto depende mucho del Hardware y posiblemente de los drivers gráficos en cada caso.

Por eso pienso, al igual que Tincho,  que la afirmación "Linux es lento" es bastante sesgada si tenemos en cuenta la cantidad de variables que intervienen en la configuración de un sistema, tanto en la parte de hardware como en la parte de controladores de hardware y software.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#8

(07-08-2021, 01:02)jguardon escribió:  Por eso pienso, al igual que Tincho,  que la afirmación "Linux es lento" es bastante sesgada

Solamente aclarar que no dije "Linux es lento", sino "Linux se pone lento" y éso por las condiciones que he señalado. Por lo general las distribuciones de Linux van bien, sin embargo pongo aquí unos comparativos:

Tiempo medido desde que se oprime el botón de encendido hasta que aparece el cuadro de login:

Arrancar Ubuntu 20.04 LTS :  120 segundos
Arrancar Linux Mint 20.2 : 180 segundos
Arrancar Mageia 7: 100 segundos
Arrancar W$ (XP, W7) : 20 segundos
Arrancar W$10: 45 segundos

Estos 5 sistemas operativos los tengo en una sola PC y el comparativo no va por el lado del hardware, sino por los sistemas operativos de arranque de cada uno de ellos.

Como ya soy viejo, no tengo ninguna prisa en que cualquier Linux arranque rápido y esté disponible "cuanto antes". Sin embargo, creo que es bueno reportar estos síntomas, por si los creadores se sienten atraídos a hacer algo al respecto.

Saludos....

Es mejor saber un poco de todo, que todo de muy poco. Lo primero, garantiza la supervivencia humana.
    ¡Gracias!
#9

(11-08-2021, 21:55)AlfredoSC escribió:  rrancar Ubuntu 20.04 LTS :  120 segundos
Arrancar Linux Mint 20.2 : 180 segundos
Arrancar Mageia 7: 100 segundos
Arrancar W$ (XP, W7) : 20 segundos
Arrancar W$10: 45 segundos

¿Están todos los sistemas operativos en el mismo disco duro físico? Es otra variable a tener en cuenta, pero seguramente (aunque yo no tengo ningún Windows junto a Linux) es cierto que la carga inicial a igualdad de condiciones es un poco más lenta en Linux.

Es probable que usando disco de arranque SSD no se noten tantas diferencias, los discos mecánicos han quedado, al menos por mi parte, solo para almacenamiento porque se notan bien lentos.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#10

(11-08-2021, 23:39)jguardon escribió:  ¿Están todos los sistemas operativos en el mismo disco duro físico?

Aquí pongo un fdisk -l de mi equipo. Los 2 discos son mecánicos.

[Imagen: oRdLhn0.png]

Y acá un poco mas en "cristiano"....

[Imagen: 8vOWq63.png]

[Imagen: JnMU1nJ.png]

Es mejor saber un poco de todo, que todo de muy poco. Lo primero, garantiza la supervivencia humana.
    ¡Gracias!


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)