Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Users only
#11

Entonces estoy generando mal el deb.
Voy a probar tildando esto, que antes estaba vacio:
[Imagen: sOJpOp0.png]

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#12

Hice un nuevo paquete marcando esos casilleros pero 3.15 como versión mínima y pasa lo mismo,me tira error en la insalación del paquete.

sudo dpkg -i databook_0.1.6-1_all.deb
(Leyendo la base de datos ... 295691 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar databook_0.1.6-1_all.deb ...
Desempaquetando databook (0.1.6-1) sobre (0.1.6-1) ...
dpkg: problemas de dependencias impiden la configuración de databook:
 databook depende de gambas3-runtime (>= 3.15); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 databook depende de gambas3-runtime (<< 3.99.0); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 databook depende de gambas3-gb-compress (>= 3.15); sin embargo:
  El paquete `gambas3-gb-compress' no está instalado.
 databook depende de gambas3-gb-compress (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-compress' no está instalado.
 databook depende de gambas3-gb-desktop (>= 3.15); sin embargo:
  El paquete `gambas3-gb-desktop' no está instalado.
 databook depende de gambas3-gb-desktop (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-desktop' no está instalado.
 databook depende de gambas3-gb-form (>= 3.15); sin embargo:
  El paquete `gambas3-gb-form' no está instalado.
 databook depende de gambas3-gb-form (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-form' no está instalado.
 databook depende de gambas3-gb-gtk3 (>= 3.15); sin embargo:
  El paquete `gambas3-gb-gtk3' no está instalado.
 databook depende de gambas3-gb-gtk3 (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-gtk3' no está instalado.
 databook depende de gambas3-gb-image (>= 3.15); sin embargo:
  El paquete `gambas3-gb-image' no está instalado.
 databook depende de gambas3-gb-image (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-image' no está instalado.
 databook depende de gambas3-gb-util-web (>= 3.15); sin embargo:
  El paquete `gambas3-gb-util-web' no está instalado.
 databook depende de gambas3-gb-util-web (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-util-web' no está instalado.
 databook depende de gambas3-gb-xml (>= 3.15); sin embargo:
  El paquete `gambas3-gb-xml' no está instalado.
 databook depende de gambas3-gb-xml (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-xml' no está instalado.

dpkg: error al procesar el paquete databook (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para gnome-menus (3.36.0-1) ...
Procesando disparadores para desktop-file-utils (0.26-1) ...
Procesando disparadores para mailcap (3.69) ...
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Se encontraron errores al procesar:
 databook


En mi sistema Debian 11, gambas (3.16) esta instalado desde las fuentes así que tal vez el paquete no encuentre las dependencias, es decir los componentes de gambas necesarios, porque sencillamente no estén registrados en el gestor de paquetes APT, voy a intentar generar el paquete con una version de gambas anterior a ver que sucede.

Saludos.

1 Saludo.
    ¡Gracias!
#13

Tal vez haya que llenar a mano la tabla de paquetes de abajo para que se incluyan en el deb...

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#14

Bueno luego de algunos experimentos di con una solución que, creo, que puede valer para varias distribuciones.

Escenario
  • Sistema de desarrollo: Debian 11 con Gambas-IDE 3.16.9 instalado desde las fuentes.
  • Programa Databook desarrollado y empaquetado con Gambas-IDE 3.16.9 y marcando versión mínima 3.12
  • Sistema destino Debian 11 sin Gambas-IDE sin ningún componente gambas, nada de nada.
Receta
  1. Instalar los componentes gambas de los que depende el programa Databook con sudo apt-get install gambas3-runtime gambas3-gb-compress gambas3-gb-desktop gambas3-gb-form gambas3-gb-gtk3 gambas3-gb-image gambas3-gb-util-web gambas3-gb-xml [1]
  2. Instalación del paquete sudo dpkg -i databook_0.1.7-1_all.deb [2]

Par amas detalle hice otro tema especifico en:
https://gambas-es.org/showthread.php?tid=534

Saludos.

1 Saludo.
    ¡Gracias!
#15

Claro, eso funciona, pero mi objetivo era crear un .deb que instale todo lo necesario. O que haga que el SO le pregunte al user: "Tengo que descargar xxx KB de archivos adicionales S/N? "

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#16

Estoy de acuerdo con Tercoide. El objetivo es generar un .deb que funcione. Lo que tincho propone es lo que se llama un workaround, es decir rodear el problema, no solucionarlo. Ahora se me plantea una pregunta: Tercoide ¿qué versión de gambas tienen los repositorios de la máquina donde quieres instalar ese deb? y ¿has probado a poner el nombre los .deb de los que depende el programa en esa pantalla donde pide la versión mínima y las dependencias?

No podemos regresar
    ¡Gracias!
#17

(13-08-2021, 17:39)Shordi escribió:  ¿has probado a poner el nombre los .deb de los que depende el programa en esa pantalla donde pide la versión mínima y las dependencias?

no, esa sera mi siguiente prueba

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#18

Esto parece ocurrir sólo cuando se instala desde los fuentes. Eso hace sospechar que esa instalación "Artesanal" deja a Gambas fuera del "circuito de dependencias", sea eso lo que sea si es que existe...

Big Grin Big Grin Big Grin

No podemos regresar
    ¡Gracias!
#19

(14-08-2021, 10:29)Shordi escribió:  Esto parece ocurrir sólo cuando se instala desde los fuentes. Eso hace sospechar que esa instalación "Artesanal" deja a Gambas fuera del "circuito de dependencias", sea eso lo que sea si es que existe...

No necesariamente. Como digo, no deberíamos instalar paquetes de gambas en nuestro PC de desarrollo si hemos compilado a mano.

Por tanto, si las pruebas se están haciendo en una máquina "virgen", el problema podría venir por las versiones de gambas que traen los repositorios oficiales versus la versión que hayamos usado para generar los paquetes (probablemente de los repos de gambas team, mucho más actuales).

Desde siempre a mi me ha funcionado la instalación de paquetes en máquinas limpias siempre que las versiones de los repos coincidan o sean mayores que la declaración de versión mínima dentro del paquete deb.

Y ya puestos, otra prueba posible sería añadir los repos de gambas-team a la máquina de pruebas virgen (sin instalar paquetes) y probar a instalar nuestro paquete a ver si así funciona. Es muy posible que haya alguna forma de que el propio instalador lo haga automáticamente en el primer paso mediante la inclusión de un script pre-hook o algo así creo que se llama, pero tendría que investigar más el tema.

Si nada de eso funciona, entonces me atrevería a decir que hay algo roto o mal hecho en la generación de paquetes y ya convendría reportarlo, pero no antes de pruebas muy concluyentes.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#20

(13-08-2021, 17:39)Shordi escribió:  ¿has probado a poner el nombre los .deb de los que depende el programa en esa pantalla donde pide la versión mínima y las dependencias?

Me parece una idea tentadora, pero en el titulo del formulario dice,bien claro, dependencias EXTRA, las dependencias de runtime etc, no son extra son esenciales, lo cual me lleva a pensar que el el proceso de generacion del paquete algo se pierde en el camino.
Otro tema vieron que en la lista de dependencias que pase antes algunas son 3.16 y otras 3.99 ? ¿No les parece curioso que existan dos números de versiones actuando en el paquete?

¿Esto de aquí debajo es lo que propones Shordi?
[Imagen: mu7i5pl.png]
Saludos.

1 Saludo.
    ¡Gracias!


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)