Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Users only
#21

Cita:¿Esto de aquí debajo es lo que propones Shordi?
Sólo pregunto si lo ha probado. Proponer no lo propongo que, ya digo, no entiendo muy bien el problema (quince años trabajando con .debs generados por gambas sin ningún problema, ni siquiera uno pequeñito, por lo que me apunto a lo dicho por jguardón sobre el gdebi en el otro hilo) pero usáis sistemas (debian y demás) que yo no uso y compiláis desde las fuentes, cosa que yo tampoco hago nunca... pues había que probar todo lo probable.

Saludos

No podemos regresar
    ¡Gracias!
#22

(14-08-2021, 17:24)Shordi escribió:  no entiendo muy bien el problema (quince años trabajando con .debs generados por gambas sin ningún problema, ni siquiera uno pequeñito,
(voy a especular un poco)
esos .debs probablemente fueron usados en PC administradas por ti mismo con la misma versión de Gambas y probablemente la misma distro ....pero cuando te sales del libreto empiezan los problemas (que tu mismo estas experimentando con tus nuevos programines)
Hoy me la pase testeando ...resumo lo actuado:
Equipos:
-PC de desarrollo: en casa, con Ubuntu 21.04 y Gambas 3.16.xxx ultimo estable instalado desde PPA
-PC de prueba: en la oficina, Ubuntu 21.04...sin nada de Gambas (nota al margen: misma distro, para no agregar problemas a los que ya tenemos)

Soft: myApp.deb generada desde la PC de desarrollo y subida a GitHub (y ahora a GitLab, donde me estoy mudando porque ahi estamos todos los G'beros)

Intento1: bajo el .deb, no lo instala por falta de dependencias

Intento2: utilizo el[Imagen: zip.gif] GambasAppInstallMaker.zip creado por Bruce Steers segun https://forum.gambas.one/viewtopic.php?f=4&t=821
-Arma un .sh basado en los componentes de nuestro programa
-creo el sh, lo sugo a Git
-lo descargo en la PC de pruebas, corre bien e instala las dependencias
-el Software Manager instala myApp.deb sin quejarse
-pero no corre porque los componentes instalados tienen problemas (probablemte son de distinta version a mi app)

Intento3: instalo Gambas3 con "sudo apt-get install gambas3" , me instala cierta version de gambas 3.15.2
-myapp no corre porque hay un fallo en la linea XXX (no existe la propiedad .Centered para los formulario)

Intento4: me bajo a regañadientes las fuentes de myapp para ver de que se trata
-le doy Run y efectivamente, esta version de Gb no tiene dicha propiedad para una Form cualquiera, ni siquiera puedo sacar la linea porque no existe el codigo, deberia editar el form1.form desde un editor externo y volver a abrir el proyecto , creo, cosa que ni siquiera voy a intentar ya que estoy escribiendo estas lineas...

Tremendo rollo, no??? Ni siquiera el programador pudo correr su programa, se imaginan un end user novel no programador???? Y estamos hablando de la misma distro!!!

Evidentemente, como he leido por ahi, Gambas es "casi" para uso personal...

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#23

¿No sería maravilloso que los programas hechos en Gambas se pudieran empaquetar directamente en formato Flatpak, Snap o AppImage? Se acabarían de una vez por todas los problemas de dependencias y los programas hechos en Gambas siempre funcionarían independientemente de la versión de Gambas.

Edito: Acabo de encontrar unas instrucciones para crear una AppImage de un programa generado en Gambas, no lo he probado, pero algo hay, si es que funciona.
https://appimage-builder.readthedocs.io/...mbas3.html
    ¡Gracias!
#24

(17-08-2021, 18:27)tercoide escribió:  (voy a especular un poco) ...
Terco, te comento algunas cosas.
  • Si en PC desarrollo y PC pruebas instalas desde PPA debería funcionar por lo que decis en pc-pruebas no esta el PPA.
  • Lo que sucede con gamabas, con el runtime de gambas para mas precisión, es que si la versión es diferente de la del IDE de desarrollo puede haber problemas. Pero ojo, los problemas pueden ser triviales como lo de .align porque es un agregado que en desarrollo esta pero en el sistema de producción no, o graves como los que un componente no existe como es el caso de OPENGL para GTK3 . Así que las soluciones son dos, o bien desarrollas con la misma versión que el sistema objetivo o en el sistema objetivo instalas la misma versión que la de desarrollo.
  • Luego Gambas team en la ultima actualización se cepillo el ppa estable directamente y lo reemplazo por la rama de pruebas. lo que genero montones de quebraderos de cabeza para los que tenian algun sistema en produccion + PPA
Saludos.

1 Saludo.
    ¡Gracias!
#25

Ahora lo entiendo:
Cita:-PC de desarrollo: en casa, con Ubuntu 21.04 y Gambas 3.16.xxx ultimo estable instalado desde PPA
-PC de prueba: en la oficina, Ubuntu 21.04...sin nada de Gambas (nota al margen: misma distro, para no agregar problemas a los que ya tenemos)
 Con eso te has contestado tú mismo:

1.-Desarrollas un programa en ganbas 3.16, y creas con él un .deb, que dice que para que funcione necesita los paquetes .deb de los componentes de la versión 3.16.

2.-Lo intentas instalar en un aparato que sólo dispone de la 3.15 en un repositorio, donde los paquetes .deb de los componentes no son los mismos, claro, que en la versión 3.16.

No te sorprendas si no funciona. La máquina y el SO son indiferentes (siempre que compartan la paquetería .deb) pero la versión de gambas debe ser la misma (o superior) en todas las máquinas. Eso no es un límite ni peculiaridad de gambas. En ningún programa o sistema existe la compatibilidad hacia arriba, sólo hacia abajo.
Enlaza el repositorio del PPA en la máquina cliente y todo funcionará sin problemas. Garantizado.

Saludos

No podemos regresar
    ¡Gracias!
#26

(17-08-2021, 20:41)Shordi escribió:  (o superior)

Eso tampoco es del todo cierto, puede pasar que uses un programa desarrollado con gambas 3.15 y lo quieras usar en otra pc con gambas 3.16 y no funcione.
Saludos.

1 Saludo.
    ¡Gracias!
#27

@tercoide Shordi lo ha explicado muy bien. Tobias Boege también en respuesta a tu pregunta en la lista internacional.

Creo haberlo dicho en otro post, si encontrásemos la forma de instalar la versión misma desde PPA que has usado para el desarrollo, sería genial.

Que el propio paquete deb instale el repositiorio justo antes de proceder a instalar el programa y sus dependencias. De esa forma, todo estaría en orden.

Algo más de info, pero no muy concreta y poco prometedora:

https://man7.org/linux/man-pages/man5/de...nst.5.html

https://unix.stackexchange.com/questions...t-commands

https://askubuntu.com/questions/101962/h...ing-upgrad


Hay pocas posibilidades de que esto funcione usando add-apt-repository, etc. dentro del script debian/preinst, ya que al ejecutarse el proceso de instalación del .deb se establece un bloqueo que evita que otros comandos apt funcionen al mismo tiempo, porque de otro modo sería un desastre para el control de los paquetes y dependencias del sistema. No obsante, yo le daría una oportunidad que naturalmente pasa por estudiar un poco cómo se crea un paquete deb.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#28

Yo entiendo lo que plantean, entonces el problema es Ubuntu:
-Gambas para desarrollo instalado desde PPA estable: 3.16 (http://ppa.launchpad.net/gambas-team/gambas3/ubuntu/)
-Gambas que me instala APT-GET: 3.15.2

porque el APT-GET no me instala 3.16??

No se como hacer lo que dice Shordi, pero que quede claro que en la PC de pruebas hago las veces de end-user, ahi mi otro yo no tiene ningun control ni conocimiento de la PC de desarrollo.

Mi proxima prueba sera crear un AppImage. Salvo que encuentre un instalador como tenia VB, o sea un programa sin dependencias de ningun tipo que se ocupa de verificar todo, bajar dependencias, chequear versiones mas nuevas, etc.

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#29

(17-08-2021, 21:48)tercoide escribió:  Yo entiendo lo que plantean, entonces el problema es Ubuntu:
-Gambas para desarrollo instalado desde PPA estable: 3.16 (http://ppa.launchpad.net/gambas-team/gambas3/ubuntu/)
-Gambas que me instala APT-GET: 3.15.2

porque el APT-GET no me instala 3.16??


Bueno, creo que el mismo problema lo tienen otras distros. Es evidente que todas tardan un tiempo en incorporar los nuevos paquetes si es que no hay un mantenedor dedicado a esa labor. Además también influyen las políticas de los desarrolladores de la propia distribución, vamos, que a menos que te vayas a una rolling distro como Arch, lo veo difícil.

Esto nos obliga a desarrollar y empaquetar necesariamente en la versión que traiga por defecto cada distribución, un auténtico calvario.

El tema de los AppImage, Snap, etc soluciona en parte esa problemática a cambio de otros inconvenientes, como paquetes demasiado grandes (dado que deben de incluir todas las dependencias dentro), un entorno discutiblemente poco seguro y algunos más que iremos descubriendo...

Bueno, nada nuevo que no supiéramos ya. Es el precio que hay que pagar por mantener el caos un poco ordenado, jajja. Si no hubiese tantas distribuciones y entornos de escritorio, etc, ya no sería un S.O. libre donde cualquiera puede hacer lo le plazca. Entonces sería otro W$.

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#30

(17-08-2021, 22:02)jguardon escribió:  todas tardan un tiempo en incorporar los nuevos paquetes

Y si, todo es esfuerzo personal. Yo, de haber podido, hubiera usado la ver de Gb mas estable posible, digamos 3.15.2 , pero luego de un intercambio el jefe máximo me pidió usar la de desarrollo para poder utilizar ciertas capacidades no presentes en la 3.15. 2 y que el, evidentemente no tenia tiempo ni ganas de incorporar a dicha versión (y para que???).
Tambien imagino que los chicos de Cannonical se deben tomar el trabajo (de tanto en tanto) de chequear que lo que hay en sus repo no tiene virus (por ejemplo que el componente binario gb.web.js no trae un virus phising que nos roba la tarjeta de credito de las webs). Y lo que dices de las AppMain es ya directamente incontrolable , 80MB en un archivo imposible de investigar que solo tiene una ventana de "Hola mundo".

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)