Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Users only
#1

Hoy hice un experimento:
-desinstale completamente Gambas3 en la PC de mi trabajo
-baje el paquete de instalacion que esta en Git de un programa hecho en Gambas
-Ubuntu lo abre con el Software, pero se queja de dependencias no satisfechas

WTF ????????
no deberian estar dentro del .deb ???????????

[Imagen: P7rMJMq.png]

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#2

No necesariamente. Un programa de gambas puede contener llamadas a librerías externas o a comandos vía shell o exec que no existan en la máquina de destino. Para eso están las opciones de "Dependencias Extra" y "Archivos Extra" en la creación del paquete de instalación. Además el gambas con el que se escribió el programa puede ser de una versión distinta al gambas de la máquina donde se intenta ejecutar, con lo que puede encontrar controles no existentes en la versión de la máquina de destino. Para eso tienes la opción de "Versión mínima de Gambas requerida" en la pantalla de "Dependencias Extra".

Estos problemas sólo pueden ser resueltos con la creación del paquete .deb o .rpm, o lo que sea.


Saludos

Lo cual me lleva a una reflexión: Por todas estas cuestiones, desde hace muchos años y dado que mis programas había que distribuirlos a través de nuestro repositorio a un montón de máquinas, tomé el hábito de no ejecutar nunca mis programas desde el IDE, salvo para modificarlos, claro. Incluso ahora cada programa que hago genero el paquete .deb y lo instalo vía gdebi en mi máquina.

¿Soy el único que hace esto?¿Siempre trabajáis desde el IDE?... Me parece peligroso y engorroso, si es que lo hacéis así.... digo.


Saludos.

No podemos regresar
    ¡Gracias!
#3

(12-08-2021, 18:21)Shordi escribió:  ¿Soy el único que hace esto?¿Siempre trabajáis desde el IDE?... Me parece peligroso y engorroso, si es que lo hacéis así.... digo.

No eres el unico, yo uso el IDE hasta que el programa tiene cierta madurez y ahí luego creo el paquete, pero últimamente encuentro muchos problemas al instalar paquetes de proyectos desarrollados con IDE en ubuntu, debian y manjaro.
Por ejemplo, hace unos minutos hice el paquete de instalación .deb para Databook. Mi sistema es debian 11 y creo paquetes para debian, todo perfecto.
Luego cuando instalo con:
sudo dpkg -i databook_0.1.2-1_all.deb
...
Seleccionando el paquete databook previamente no seleccionado.
(Leyendo la base de datos ... 295679 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar databook_0.1.2-1_all.deb ...
Desempaquetando databook (0.1.2-1) ...
dpkg: problemas de dependencias impiden la configuración de databook:
 databook depende de gambas3-runtime (>= 3.16); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 databook depende de gambas3-runtime (<< 3.99.0); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 databook depende de gambas3-gb-image (>= 3.16); sin embargo:
  El paquete `gambas3-gb-image' no está instalado.
 databook depende de gambas3-gb-image (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-image' no está instalado.
 databook depende de gambas3-gb-form (>= 3.16); sin embargo:
  El paquete `gambas3-gb-form' no está instalado.
 databook depende de gambas3-gb-form (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-form' no está instalado.
 databook depende de gambas3-gb-compress (>= 3.16); sin embargo:
  El paquete `gambas3-gb-compress' no está instalado.
 databook depende de gambas3-gb-compress (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-compress' no está instalado.
 databook depende de gambas3-gb-desktop (>= 3.16); sin embargo:
  El paquete `gambas3-gb-desktop' no está instalado.
 databook depende de gambas3-gb-desktop (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-desktop' no está instalado.
 databook depende de gambas3-gb-util-web (>= 3.16); sin embargo:
  El paquete `gambas3-gb-util-web' no está instalado.
 databook depende de gambas3-gb-util-web (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-util-web' no está instalado.
 databook depende de gambas3-gb-xml (>= 3.16); sin embargo:
  El paquete `gambas3-gb-xml' no está instalado.
 databook depende de gambas3-gb-xml (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-xml' no está instalado.

dpkg: error al procesar el paquete databook (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para gnome-menus (3.36.0-1) ...
Procesando disparadores para desktop-file-utils (0.26-1) ...
Procesando disparadores para mailcap (3.69) ...
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Se encontraron errores al procesar:
 databook


Instale gambas desde las fuentes (3.16) asi que asumo que si uno desarrolla programas con gambas jamas debe usar la version desarrollo, debe usar la version que ofrece el gestor de paquetes de la distribución, pero incluso haciendo así no hay garantías de que el programa que uno desarrolla funcione en otros sistemas.

Saludos.

1 Saludo.
    ¡Gracias!
#4

Pues yo he bajado el databook desde el git, he generado el paquete para ubuntu/mint y lo he instalado sin ningún problema. Tan sólo aprecio que está hecho con el componente gb.gui, lo que genera un paquete .deb por cada librería (qt4,qt5 y gtk3) más el genérico que decide cuál debe instalarse en el sistema. Tal vez eso tenga algo que ver, si no se generan todos los paquetes o no existen todas las librerías en la máquina de destino, lo mismo es un follón... Gambas sigue muy atado al concepto de programas instalados desde un repositorio, lo cual es maravilloso si dispones de uno (como yo disponía), pero en las instalaciones "artesanales", parece que no tanto...


Saludos.

No podemos regresar
    ¡Gracias!
#5

(12-08-2021, 19:03)Shordi escribió:  Tan sólo aprecio que está hecho con el componente gb.gui, lo que genera un paquete .deb por cada librería (qt4,qt5 y gtk3) más el genérico que decide cuál debe instalarse en el sistema. Tal vez eso tenga algo que ver, si no se generan todos los paquetes o no existen todas las librerías en la máquina de destino, lo mismo es un follón...

Pues no, hice la prueba de ponerlo todo en gb.gtk3 y genero solo el paquete databook_0.1.5-1_all.deb luego mas de lo mismo.
sudo dpkg -i databook_0.1.5-1_all.deb
(Leyendo la base de datos ... 295691 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar databook_0.1.5-1_all.deb ...
Desempaquetando databook (0.1.5-1) sobre (0.1.5-1) ...
dpkg: problemas de dependencias impiden la configuración de databook:
 databook depende de gambas3-runtime (>= 3.16); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 databook depende de gambas3-runtime (<< 3.99.0); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 databook depende de gambas3-gb-image (>= 3.16); sin embargo:
  El paquete `gambas3-gb-image' no está instalado.
 databook depende de gambas3-gb-image (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-image' no está instalado.
 databook depende de gambas3-gb-gtk3 (>= 3.16); sin embargo:
  El paquete `gambas3-gb-gtk3' no está instalado.
 databook depende de gambas3-gb-gtk3 (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-gtk3' no está instalado.
 databook depende de gambas3-gb-form (>= 3.16); sin embargo:
  El paquete `gambas3-gb-form' no está instalado.
 databook depende de gambas3-gb-form (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-form' no está instalado.
 databook depende de gambas3-gb-compress (>= 3.16); sin embargo:
  El paquete `gambas3-gb-compress' no está instalado.
 databook depende de gambas3-gb-compress (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-compress' no está instalado.
 databook depende de gambas3-gb-desktop (>= 3.16); sin embargo:
  El paquete `gambas3-gb-desktop' no está instalado.
 databook depende de gambas3-gb-desktop (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-desktop' no está instalado.
 databook depende de gambas3-gb-util-web (>= 3.16); sin embargo:
  El paquete `gambas3-gb-util-web' no está instalado.
 databook depende de gambas3-gb-util-web (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-util-web' no está instalado.
 databook depende de gambas3-gb-xml (>= 3.16); sin embargo:
  El paquete `gambas3-gb-xml' no está instalado.
 databook depende de gambas3-gb-xml (<< 3.99.0); sin embargo:
  El paquete `gambas3-gb-xml' no está instalado.

dpkg: error al procesar el paquete databook (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para gnome-menus (3.36.0-1) ...
Procesando disparadores para desktop-file-utils (0.26-1) ...
Procesando disparadores para mailcap (3.69) ...
Procesando disparadores para hicolor-icon-theme (0.17-2) ...
Se encontraron errores al procesar:
 databook


Saludos.

1 Saludo.
    ¡Gracias!
#6

Pareciera que tienes un potaje de versiones de gambas ahí entre la 3.16 y la 3.99 que es la de desarrollo... ¿Desinstalaste ésta última del todo? ¿Has probado a eliminar el contenido de la carpeta databook/.gambas? Yo he observado que, aunque se supone que se recompila todo cuando se genera el paquete pareciera que no siempre es así y hay problemas que desaparecen al elimininar los viejos compilados y regenerarlos.

Pero desde luego es un tema de versiones de gambas en el ordenador de origen, que establece dependencias múltiples sobre los componentes de gambas.

Saludos.

No podemos regresar
    ¡Gracias!
#7

El problema que planteo es que el .deb no trae NINGUNA versión del runtime de gambas ni los componentes necesarios, por lo tanto la conclusión rápida que hago es que el que hizo el empaquetador .deb del IDE (Benoit o quien fuere) presupone que el end user tiene la misma versión de Gambas instalado en su PC. Esto es un poco restrictivo para un usuario novel no programador. El empaque correcto debería incluir exactamente los mismos runtimes que tiene el programador a efectos de que el .deb funcione en una instalacion nueva de linux, por ejemplo.

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#8

Los paquetes deb que genera gambas nunca han contenido otra cosa que no sea el propio programa. Las dependencias se resuelven a la hora de instalarse el paquete siempre que existan en los repos de la distribución.

Por otra parte, que yo sepa, dpkg no instala dependencias, solo instala el paquete si las posibles dependencias están resueltas. Desconozco ahora mismo si hay un modificador para forzar la resolución e instalación de las dependencias.

Sigo pensando que es un grave error instalar nuestros programas en la máquina de desarrollo si hemos instalado gambas mediante compilación manual. Eso genera infinidad de errores y problemas. Lo mejor es hacerlo en una VM o en otro PC.

My two cents...

Saludos

Por favor, usa el corrector ortográfico antes de pulsar el botón 'Enviar'
    ¡Gracias!
#9

Pues Ubuntu 21.04 no fue capaz de resolver las dependencias por si mismo y, por lo tanto, se nego a instalar mi programa.

Por consiguiente el .deb que genera el IDE no tiene ninguna utilidad, excepto que la maquina destino tenga instalado exactamente la version de gambas que la del programador (o >minima).

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#10

Disiento: Me he pasado los últimos 15 años de vida laboral generando .debs que se instalaban en variedad de máquinas con variedad de versiones del sistema. Cuando generas el .deb tienes una opción de marcar la versión mínima de gambas requerida. Si ahí colocas la versión que quieras, las librerías y dependencias deberían ser las correctas.
Pasa los errores que te de. Teniéndolos a la vista es más fácil la ayuda... o, si quieres generamos el deb en nuestras máquinas y te lo pasamos para que pruebes con ellos. Si entonces funciona es evidente que tienes un problema con la instalación... o lo que sea.

Saludos.

No podemos regresar
    ¡Gracias!


Salto de foro:


Usuarios navegando en este tema: 2 invitado(s)