Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

LLega Gambas 3.17.0
#1

Hola a todos.

Hoy el Linux Mint 20.3 me ha mostrado las  actualizaciones y entre ellas estaba GAMBAS 3.17.0, lo actualice para ver sus mejoras  Big Grin, pero ahora resulta que ninguna aplicación tipo Web se ejecuta. Confused .

1- ¿Alguien lo ha probado...?
2- ¿Cómo retrocedo a la versión 3.16.3?

Gracias por sus posibles repuestas.
    ¡Gracias!
#2

Ni idea pero resulta que lleva un nuevo visor web "mas ligero" a ver si es por eso....

Suerte

No podemos regresar
    ¡Gracias!
#3

Ya pude publicar en el Bug Tracker y respondieron: esta en  reparación.

Por el momento recomiendan realizar estos pasos:
  1. Seleccionar el menú: Depuración / Configuración
  2. Aparecerá la ventana: Debugger Configuration
  3. Activar la opción: Depurador / Usar el servidor HTTP Incrustado
[Imagen: TfMs6Aw.png]

Ahora me toca verificar los errores que han salido con la nueva versión ... Dodgy

Saludos.
    ¡Gracias!
#4

(10-03-2022, 18:49)omoreno escribió:  1- ¿Alguien lo ha probado...?

Si, yo la estoy usando ahora mismo, tiene muchas mejoras respecto a 3.16 es una versión con muchos cambios asi que es normal que algo no funcione.
Echa un vistazo a los cambiosen el wiki, algo leí de pasada sobre cambios en los controles web.
(10-03-2022, 18:49)omoreno escribió:  2- ¿Cómo retrocedo a la versión 3.16.3?

Una vez que cambian el ppa borran el anterior, asi que las opciones que tienes son:
  • Usar una distor que tenga en sus repos la version 3.16
  • make install descargando la rama de la versión 3.16
  • Modificar tu programa para que funcione con 3.17

1 Saludo.
    ¡Gracias!
#5

Me quedo con la 3.17.0

Mientras luchaba con el código para ver por que no se ejecutaba el servidor incrustado, desactive una linea de una subrutina global y por eso no se cargaba ninguna WebTable... Blush.

Bueno si tiene muchas mejoras, una de las que me percate rápido fue en los SetFocus(), ahora el foco salta de forma correcta a los Webuttons.

Lo malo es que aun se mantiene el problema de las selecciones múltiples en los WebRadioButtons cuando cargas en varios TAB del navegador.

Continuare probando.

Saludos.
    ¡Gracias!
#6

Yo todavia sigo con la  3.17.0

Probé un momento pero no me cargaba  , se que tiene mejoras y lo probaré estos días . Revisaré el tema  selecciones múltiples en los WebRadioButtons
ya os voy contando
    ¡Gracias!
#7

Cita:Hoy el Linux Mint 20.3 me ha mostrado las  actualizaciones y entre ellas estaba GAMBAS 3.17.0, lo actualice para ver sus mejoras

Supongo que esto es añadiendo el ppa. Puede ser raro que una distro como Linux Mint, ya incorpore la 3.17.

Espero que con la 3.17.2 se solucionaran los problemas que comentáis.
 
(11-03-2022, 10:44)tincho escribió:  Una vez que cambian el ppa borran el anterior, asi que las opciones que tienes son:

Cuando en su día salió una versión apresurada de Gambas 3.X que daba bastante la lata, pude bajar del ppa (rebuscando) la 3.15.
Así que debió ser la 3.16 la problemática ( en su día ).

Como usaba dos distros, en una usaba la 3.16 y en la otra (más antigua) la 3.15. Con el tiempo se arregló y la 3.15 fue desapareciendo
de la distro. Para los que sois profesionales o tenéis usuarios que dependen de vosotros, este problema no es fácil y hay que tener cuidado
con las novedades.

Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!
#8

(29-05-2022, 12:59)Shell escribió:  Como usaba dos distros, en una usaba la 3.16 y en la otra (más antigua) la 3.15. Con el tiempo se arregló y la 3.15 fue desapareciendo
de la distro. Para los que sois profesionales o tenéis usuarios que dependen de vosotros, este problema no es fácil y hay que tener cuidado
con las novedades.

Saludos

¡Vaya si hay que tenerlo! En mi ex-empresa se dieron un batacazo enorme allá por abril de 2021 cuando el gambas 3.16 llevaba un bug que hacía que el control trayIcon no funcionase. Todos los programas de la empresa dependían de eso porque el programa que conecta con la vpn lo usa. Fue un desastre importante.
Ahora usan la 3.17.2 y todo funciona otra vez.
La solución es meter los paquetes de gambas en el repositorio interno de la empresa y actualizar éstos sólo cuando estemos seguros de que va a funcionar todo.

Saludos.

No podemos regresar
    ¡Gracias!
#9

Hola Shell.

Esto es lo que tengo en el Linux Mint:
[Imagen: Nskf6fu.png]

En la 3.17.2 han resuelto la mayoría de los bug que he reportado, pero ahora estoy esperando la 3.17.3 porque en la 3.17.2 aun queda un bug en el objeto WebTree el cual ya esta reparado en la versión de desarrollo 3.17.90.

Saludos.
    ¡Gracias!


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje
Último mensaje por tincho
16-05-2021, 13:16

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)