Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Retraso al escribir en el editor
#1

Buenas!.

¿ No tenéis a veces un problema de retraso al escribir en el editor ?.  En algunos momentos va despacito mostrando las letras que escribes,
pero no es habitual.

Es la Gambas 3.17.2
Linux Mint 20.3

Y para rizar el rizo.

Supongamos que el empaquetador crea los paquetes de Gambas3 bajo una máquina Intel y luego lo uso en un AMD,
¿ no crearía algún tipo de "problema" por pequeño que sea ?.

Se habla tanto de estas cosas en el mundo gamer. Juegos mejor optimizados para un procesador que otro, que luego influye en el rendimiento.
¿ Qué le impide a Gambas que no tenga algo parecido ?


Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!
#2

Cita:¿ No tenéis a veces un problema de retraso al escribir en el editor ?.  En algunos momentos va despacito mostrando las letras que escribes,
pero no es habitual.
 
Si te refieres al editor del IDE de Gambas, no. No he notado ningún retraso.
Cita:Supongamos que el empaquetador crea los paquetes de Gambas3 bajo una máquina Intel y luego lo uso en un AMD,
¿ no crearía algún tipo de "problema" por pequeño que sea ?.
Pues no lo sé por cuanto yo sólo he probado crear paquetes para Ubuntu/Mint o para Debian. Nunca he tenido problemas. Lo del AMD no lo he probado nunca... salvo en programas hechos en Gambas 3.12 en una Raspberry Pi. y tampoco tuve ningún problema.
Me falta probar el tema del backport que impulsó Tincho a ver si puedo meterle el gambas 3.17 a la Raspberry. A ver si encuentro un rato y lo pruebo.

Saludos

No podemos regresar
    ¡Gracias!
#3

(18-06-2022, 10:57)Shordi escribió:  Si te refieres al editor del IDE de Gambas, no. No he notado ningún retraso.

Si.

Desde que uso el AMD, a veces noto algo raro. No es algo constante, tiene momentos. Pero no sé como "pillar" ese momento.
Estuve poniendo la utilidad htop a ver si veía un pico de proceso, pero no.

Cuando escribimos en el editor hace un atucompletado de lo que escribes para ahorrarnos tener que teclear todo el comando.
Ese puede ser el momento.
 
(18-06-2022, 10:57)Shordi escribió:  Pues no lo sé por cuanto yo sólo he probado crear paquetes para Ubuntu/Mint o para Debian. Nunca he tenido problemas. Lo del AMD no lo he probado nunca... salvo en programas hechos en Gambas 3.12 en una Raspberry Pi. y tampoco tuve ningún problema.

Pero paquetes de Gambas no hay según procesador. Es según la distros y casos especiales como la Raspberry Pi ( que supongo que tendrá su propio
ppa).

No me refiero a crear un a crear una instalación de una aplicación propia, me refiero a todo el conjunto de Gambas3, la que descargamos del ppa.

A ver si hay algún usuario de la comunidad que use AMD. Siempre puedo poner el Intel y comparar, pero son cosas muy precisas.
Un momento determinado.

Siempre podría compilar las fuentes y ver que hace.

Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!
#4

Buenas!

Abrí Gambas desde la consola y mientras escribía  una vez más se notaba el retraso.
En la consola mostraba un mensaje como este a distintas horas, mientras escribía parte de un código.
 
Cita:(process:5236): GLib-CRITICAL **: 16:25:45.254: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:27:03.158: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:27:48.918: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:29:18.370: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:30:35.722: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:31:12.418: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:31:42.513: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:32:29.383: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:33:09.813: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:39:54.538: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:44:21.304: Failed to set scheduler settings: Operation not permitted

(process:5236): GLib-CRITICAL **: 16:46:03.909: Failed to set scheduler settings: Operation not permitted 

Veré que encuentro luego. En ese momento no miré cual era el proceso.
La aplicación que estaba creando es de QT.

Gambas 3.17.2
Linux Mint 20.3

La primera vez que intenté crear el proyecto, se quedo en la bola, dando vueltas. Tuve que cerrar y abrir de nuevo,
para crear un proyecto nuevo. Pero esto puede ser algo ocasional. Como dije no es algo que suela pasar, pero si que pasa.

Si el error se produce mientras se está escribiendo, normal que exista un leve retraso.

Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!
#5

Os doy un poco de más detalle del error de arriba y su procedimiento, sobre todo al que pertenece.
Me ha vuelto a mostrar:
 
Cita:(process:5032): GLib-CRITICAL **: 15:41:01.841: Failed to set scheduler settings: Operation not permitted

El id del proceso pertenece a...vaya ha vuelto a desaparecer el proceso!. Confused
Si es que no puedo ver tanto Tom y Jerry.

De todas formas, ayer también me avisó, (ahora arranco últimamente gambas3 desde la consola y te enteras de cosas que de otra forma no ves ).
Por ejemplo, un error creado a conciencia con una base de datos.

Estos errores quiźas deberían ser derivados a la consola del propio Gambas.
A menos que "no interese" que se vean..jeje. Rolleyes

Que luego "za zuzta" el usuario y da la lata. Es que a veces lo ususarios son un coñazo..eh?. Tongue


Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
[-] Los siguientes 1 usuarios dice gracias a Shell por este post:
  • Shordi
    ¡Gracias!
#6

Si vuelve a ocurrir os aviso (sobre todo a ver que proceso es). Es que es una lotería. Ahora va perfecto. Es que no entiendo el comportamiento.
Se arreglan las cosas solas, alucino!. (Debo tener un ejercito oculto de ingenieros en el ordenador). Vaya con los cambios.

Saludos

"El lobo siempre será malo si sólo escuchamos a Caperucita.". El lobo.
    ¡Gracias!


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)