Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

Ayuda para instalar Gambas3 desde Gitlab
#1

Hola a todos

En una maquina virtual instale Lubuntu 22.04, luego instale gambas3 con estos pasos:
Código:
sudo add-apt-repository ppa:gambas-team/gambas-daily
sudo apt-get update
sudo apt-get install gambas3
sudo apt-get update
sudo apt-get upgrade

Como GAMBAS BUG TRACKER, mandan a verificar en Gitlab, decidí desinstalar e instalar desde Gitlab con estos pasos:
Para desinstalar:
Código:
sudo apt-get remove --purge gambas3*
sudo apt-get autoremove
sudo apt-get autoclean

Para instalar desde el Gitlab:
Código:
git clone --depth=1 https://gitlab.com/gambas/gambas.git
git pull
./reconf-all
./configure -C --disable-keyring –disable-qt4  ó  ./configure -C -q
make -j $(nproc)
sudo make install

Al finalizar el icono de Gambas aparece en el menú del sistema operativo, pero no ejecuta el IDE de Gambas3.

Nota: el comando sudo make install genera los siguientes mensajes al finalizar:

Making install in man
 /usr/bin/mkdir -p '/usr/share/man/man1'
 /usr/bin/install -c -m 644 gambas3.1 gbs3.1 gbw3.1 '/usr/share/man/man1'
Making install in .

||
|| Unable to compile 'gb.gui.base' component
|| Unable to compile 'gb.form' component
|| Unable to compile 'gb.form.dialog' component
|| Unable to compile 'gb.form.mdi' component
|| Unable to compile 'gb.db.form' component
|| Unable to compile 'gb.desktop' component
|| Unable to compile 'gb.report' component
|| Unable to compile 'gb.report2' component
|| Unable to compile 'gb.chart' component
|| Unable to compile 'gb.net.pop3' component
|| Unable to compile 'gb.memcached' component
|| Unable to compile 'gb.map' component
|| Unable to compile 'gb.media.form' component
|| Unable to compile 'gb.form.editor' component
|| Unable to compile 'gb.dbus.trayicon' component
|| Unable to compile 'gb.form.terminal' component
|| Unable to compile 'gb.term.form' component
|| Unable to compile 'gb.form.print' component
|| Unable to compile 'gb.scanner' component
|| Unable to compile 'gb.form.htmlview'
|| Unable to compile gambas3
|| Unable to compile gbs3
||

Podrían indicarme los pasos correctos.

Gracias por sus posibles repuestas.
    ¡Gracias!
#2

Nunca lo he instalado desde gitlab, sorry. Me confío mejor al viejo sistema de los repositorios... y siempre instalo el "estable", no el daily. Seguro que por aquí hay gente que te puede ayudar... la pregunta, sólo por curiosidad es: ¿Por qué? ¿Qué problemas te dio la primera instalación desde el repo?

Saludos

No podemos regresar
    ¡Gracias!
#3

(02-11-2022, 17:58)Shordi escribió:  ... la pregunta, sólo por curiosidad es: ¿Por qué? ¿Qué problemas te dio la primera instalación desde el repo?

Saludos

Hola Shordi.

Desde "repo" no me dio ningún problema en la instalación, solo que en Bug Tracker alguna veces me responden que verifique las reparaciones de los BUG en Gitlab.

El nuevo problema con el IDE instalado desde "repo" es que la ejecución de los programas tipo WEBFORM generan un error "gb.geom", busque en las lista y ya lo habían reportado, pero la respuesta fue: "Reparado... favor verificar en Gitlab".
Supongo que en Gitlab esta lo ultimo de lo ultimo... Huh, por eso me atreví a probar desde una maquina virtual.

Saludos.
    ¡Gracias!
#4

Buenas!.

Si es la Lubuntu 22.04 es la hermana de Ubuntu 22.04. La Jammy.

Instala sus dependencias:

Bash
  1. apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y build-essential g++ automake autoconf libtool libbz2-dev libzstd-dev libmysqlclient-dev unixodbc-dev libpq-dev libsqlite0-dev libsqlite3-dev libglib2.0-dev libgtk2.0-dev libcurl4-gnutls-dev libgtkglext1-dev libpcre3-dev libsdl-sound1.2-dev libsdl-mixer1.2-dev libsdl-image1.2-dev libxml2-dev libxslt1-dev librsvg2-dev libpoppler-dev libpoppler-private-dev libpoppler-glib-dev libpoppler-cpp-dev libasound2-dev libdirectfb-dev libxtst-dev libffi-dev libglew-dev libimlib2-dev libv4l-dev libsdl-ttf2.0-dev libgdk-pixbuf2.0-dev linux-libc-dev libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libcairo2-dev libgsl-dev libncurses5-dev libgmime-3.0-dev llvm-dev llvm libalure-dev libgmp-dev libgtk-3-dev libsdl2-dev libsdl2-mixer-dev libsdl2-ttf-dev libsdl2-image-dev sane-utils libdumb1-dev libssl-dev libqt5opengl5-dev libqt5svg5-dev libqt5webkit5-dev libqt5x11extras5-dev qtbase5-dev qtwebengine5-dev libwebkit2gtk-4.0-dev git



Luego los pasos de la instalación desde fuente es:

Bash
  1. ./reconf-all
  2.  
  3. ./configure -C --disable-keyring --disable-qt4



Te adjunto el enlace:

Ubuntu Jammy (22.04)

A ver que tal te va con esto. Wink

Saludos

"El buen perfume en frasco pequeño se vende"
    ¡Gracias!
#5

Gracias Shell.

Ciertamente faltaban las dependencias.

Saludos.
    ¡Gracias!


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje

Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)