Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

PSeInt - Pseudo interprete
#1

Hola amigos.
Como didáctico es didáctico, desde la charla en otro tema sobre programación en español me puse a revolver la red de redes y encontré algunas cosas interesante una es PSeudo Intérprete, PSeInt.
https://es.wikipedia.org/wiki/PSeInt
Este es mi primer programa y pantallazo:
[Imagen: skhfoQv.png]
Saludos.
    ¡Gracias!
#2

Muy bueno para niños en edad de escuela primaria

"Es mejor saber todo de muy poco que muy poco de todo" - anonimo
    ¡Gracias!
#3

(05-05-2021, 14:46)tercoide escribió:  Muy bueno para niños en edad de escuela primaria

Si, yo pensé lo mismo. Bueno es una herramienta mas para educar.
Saludos.
    ¡Gracias!
#4

Hola!.

El ejemplo es muy sencillo. Big Grin

Yo no díría que sea para niños.  Shy
Es para cualquier programador que comienza y no quiere complicarse con sintaxis de lenguajes.

Lo he usado bastante. Le encontré un problema con las funciones pero ahora no recuerdo si era con los argumentos o
con el retorno. A ver si este era el ejemplo que hice en su día.
Cita: 
Funcion numeros<-Ordena(numeros, maximo)
        
    Definir cambio Como Logico;
    definir a Como Entero;
    definir aux Como Entero;
    
    cambio <- Verdadero;
    
    Mientras  cambio Hacer
        cambio <- Falso;
        // Un indice menos para poder comparar con el número siguiente sin salirse de los inidces del array.
        para a desde 1 hasta maximo con paso 1
            si numeros[a] > numeros[a + 1] Entonces                
                aux <- numeros[a];
                numeros[a] <- numeros[a + 1];
                numeros[a + 1] <- aux;
                cambio <- Verdadero;
            FinSi            
        FinPara        
    FinMientras
        
FinFuncion

Algoritmo OrdenarArray
    
    Dimension valores[5];
            
    valores[1] <- 7;
    valores[2] <- 10;
    valores[3] <- 23;
    valores[4] <- 89;
    valores[5] <- 10;
        
    valores <- Ordena(valores, 5);
    
    para a desde 1 hasta 5 con paso 1
        escribir ConvertirATexto(valores[a]) + " ",Sin Saltar;
    FinPara
    
    
FinAlgoritmo



[Devuelve este error:
Cita:Lin 35 (inst 1): ERROR 200: Faltan subindices para el arreglo (VALORES)



Creo que es cuando se le pasa un array.

Para niños estuve hace unos días en el que programabas los movimientos del robot del Despertar de la Fuerza de Star Wars.
Me creía que era otra cosa. Smile

Era como Scratch.

Saludos

Variable cambiada de "i" a "a" que el editor le tiene manía con los indices.. Dodgy

"¿Activar antivirus? ¡Me estoy bajando porno! No." - Bender.
    ¡Gracias!
#5

Quiere un elemento concreto por lo que parece.

[Imagen: Pg5Ss87.png]

El indice de los array pueden configurarse para que comiencen desde 0 o desde 1.

[Imagen: 38YFUYf.png]

Hay perfiles de una gran cantidad de escuelas. Con tal de ver su escudo.. Tongue

Saludos

"¿Activar antivirus? ¡Me estoy bajando porno! No." - Bender.
    ¡Gracias!
#6

“Nunca confíes en un ordenador que te pueda lanazar a ti por la ventana” Morpheus
[Imagen: cCaVZfI.png]
    ¡Gracias!
#7

(06-05-2021, 15:58)tincho escribió:  “Nunca confíes en un ordenador que te pueda lanazar a ti por la ventana” Morpheus

Big Grin Big Grin

"¿Activar antivirus? ¡Me estoy bajando porno! No." - Bender.
    ¡Gracias!


Salto de foro:


Usuarios navegando en este tema: 1 invitado(s)