Este foro usa cookies
Este foro utiliza cookies para almacenar su información de inicio de sesión si está registrado y su última visita si no lo está. Las cookies son pequeños documentos de texto almacenados en su computadora; las cookies establecidas por este foro solo se pueden usar en este sitio web y no representan ningún riesgo de seguridad. Las cookies en este foro también rastrean los temas específicos que ha leído y la última vez que los leyó. Si Ud. continúa navegando, entenderemos que acepta todas las cookies.

Se almacenará una cookie en su navegador, independientemente de la elección, para evitar que se le vuelva a hacer esta pregunta. Podrá cambiar la configuración de sus cookies en cualquier momento utilizando el enlace en el pie de página.

Borrar este aviso
El foro antiguo se encuentra accesible desde https://foro.gambas-es.org en modo de solo lectura.

Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5

No puedo instalar los paquetes de instalacion de gambas
#1

Tengo instalado debian 10 e instale gambas3  compilándolo (versión 3.15.1) e instalándolo según la  wiki. Pero al instalarlo así, en apt no aparece instalado, creo un paquete de instalación en gambas y lo crea pero al intentar instalarlo con gdebi me dice :
Error: no se puede satisfacer la dependencia: gambas3-runtime (>=3.15).
Imagino que hay que crear los paquetes de gambas3, alguien sabe como empaquetar gambas, pues estoy pez en eso.
#2

Creo que el problema esta en gdebi por lo que relatas para el ese programa no existe y podria ser justo por un problema de no listado de programas en el gestor de paquetes apt.

Mira a ver si esto te iria bien →
https://askubuntu.com/questions/85269/ho...nstalled-t
https://askubuntu.com/questions/28372/ho...gh-apt-get

https://packaging.ubuntu.com/html/packag...tware.html
https://www.cyberciti.biz/faq/how-to-get...or-ubuntu/
Nos estamos metiendo en unos fregaos con esto de la version 3.15 y debian que van a dar que hablar. Pero la causa de esto esta del lado de paquete mantenido para la distro no es un problema del software - Gambas.
Smile
#3

http://novatocodegambas.blogspot.com/202...n-105.html

El tiempo de las manifestaciones caducó pero el boicot con auto sacrificio es el camino para derrotar al sistema.
#4

(04-09-2020, 01:48)kokodrilo escribió:  http://novatocodegambas.blogspot.com/202...n-105.html

Si cambio los repositorios a sid (inestable) como pones en tu página, al intentar instalar gambas, se me crean múltiples paquetes rotos y me temo que me cargaré el sistema.
#5

(05-09-2020, 12:08)angelnu escribió:  
(04-09-2020, 01:48)kokodrilo escribió:  http://novatocodegambas.blogspot.com/202...n-105.html

Si cambio los repositorios a sid (inestable) como pones en tu página, al intentar instalar gambas, se me crean múltiples paquetes rotos y me temo que me cargaré el sistema.
respalda datos, instala debian buster, instala gambas3 y tema solucionado

El tiempo de las manifestaciones caducó pero el boicot con auto sacrificio es el camino para derrotar al sistema.
#6

(05-09-2020, 12:08)angelnu escribió:  
(04-09-2020, 01:48)kokodrilo escribió:  http://novatocodegambas.blogspot.com/202...n-105.html

Si cambio los repositorios a sid (inestable) como pones en tu página, al intentar instalar gambas, se me crean múltiples paquetes rotos y me temo que me cargaré el sistema.

No debes mezclar repositorios de diferentes tipos de ramas Debian mas que nada da errores ya que te entran paquetes de la rama Sid en este caso los cuales son del ciclo de desarrollo. La rama sid suele ser usada como plataforma para entrada de nuevos paquetes y corrección de errores, pasa allí unas revisiones de más o menos tiempo y esos paquetes pasan después a la rama estable. Esto puede suceder durante un tiempo en que la distro ya ha cambiado mucho en kernel, esto en la rama estable de Debian - en suma son ramas diferentes con repositorios con paquetería nueva en un lado y con revision aún en activo y en el otro paquetería ya estable y ya revisada.

Lo que tendrías que hacer en ese caso serian 3 pasos, primero en /etc/apt/sources.list bloquear / comentar los sources sid.
Abrir synaptic y hacer un update.
En el mismo synaptic te darán unos errores de paquetes huérfanos, mirar bien si hay algunos relativos a tu ambiente de trabajo o tema gráfico, si es así y se complica la cosa podrías quedar sin sesión o X gráficas. Míralos bien, si no te entraron updates e hiciste upgrades de paquetes críticos como de tema gráfico o de ambiente, kernel no tendrás muchos problemas en eso creo yo, puede suceder si ya haces upgrades y ya llevas muchas updates que generan otras dependencias en sistema con updates y upgrades y que son usados en tareas básicas o criticas de sistema.
Marcarlos para remoción completa, muy importante completa no solo remoción, es como si hicieras un purge remove ese comando te va a ser esencial en este caso.
Hecho eso si todo sale bien en synpatic te marcará updates de paquetes que hayan sido downgradeados y removidos a causa del remover de sources sid, márcalos y haz el update upgrade a esos paquetes.
Haz un reinicio a ver si todo esta como estaba.

Synaptic es la mejor forma de hacerlo para no tirar de comandos pero a veces el mismo synaptic se atraganta siendo incapaz de resolver paquetes; si fuera así tendrías que tirar si o si de comandos.

También puedes hacer lo que dijo arriba el amigo pero esa seria una ultima etapa si intentas arreglarlo por synaptic y /etc/apt/sources.list.

Smile

Más arriba sobre lo que comentas de gdebi y te respondí me acuerdo ahora de una cosa que podría ayudar pero no lo sé.
A veces el gestor de un instalador se lía y no sabe muy bien que hacer.
Inténtalo a pelo con comando sudo dpkg-i /tu/directorio/del/paquete/que/creaste/de/gambas
, en teoría te tirará el error de esa dependencia pero podría ser que via comando te presentara alguna resolución autonoma por instalación de dependencias. Pruébalo, a lo mejor funciona.

Pero antes hace eso que comento arriba de remover el sid repository de tu sources.list
#7

(05-09-2020, 23:40)portaro escribió:  No debes mezclar repositorios de diferentes tipos de ramas Debian
No llegue a hacer nada al ver todos los problemas que me creaba con muchos paquetes que había que eliminar y otros que se marcaban como rotos lo cancele y borre el repositorio sid.
Respecto a lo de instalar de nuevo debian con la rama sid, la verdad no me apetece cambiar un sistema que funciona muy bien por otro que tal vez no aparte del tiempo.

He intentado instalar con dpkg -i pero me pone :

Preparando para desempaquetar gestion01_0.1.6-1_all.deb ...
Desempaquetando gestion01 (0.1.6-1) ...
dpkg: problemas de dependencias impiden la configuración de gestion01:
 gestion01 depende de gambas3-runtime (>= 3.15); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 gestion01 depende de gambas3-runtime (<< 3.99.0); sin embargo:
  El paquete `gambas3-runtime' no está instalado.

etc. etc. con todas las dependencias de gambas

El problema creo que al instalar gambas de las fuentes con:
./reconf-all
./configure -C
make
sudo make install

El sistema de paquetes de debian no lo reconoce como instalado, pero están instalados. Creo que la solución seria empaquetar Gambas 3.15 pero no me veo capacitado para hacerlo, ahora lo que hago es en el otro ordenador instalo gambas desde las fuentes y en vez de crear paquetes para debian creo el ejecutable lo copio y funciona igual.
#8

(06-09-2020, 12:04)angelnu escribió:  
(05-09-2020, 23:40)portaro escribió:  No debes mezclar repositorios de diferentes tipos de ramas Debian
No llegue a hacer nada al ver todos los problemas que me creaba con muchos paquetes que había que eliminar y otros que se marcaban como rotos lo cancele y borre el repositorio sid.
Respecto a lo de instalar de nuevo debian con la rama sid, la verdad no me apetece cambiar un sistema que funciona muy bien por otro que tal vez no aparte del tiempo.

He intentado instalar con dpkg -i pero me pone :

Preparando para desempaquetar gestion01_0.1.6-1_all.deb ...
Desempaquetando gestion01 (0.1.6-1) ...
dpkg: problemas de dependencias impiden la configuración de gestion01:
 gestion01 depende de gambas3-runtime (>= 3.15); sin embargo:
  El paquete `gambas3-runtime' no está instalado.
 gestion01 depende de gambas3-runtime (<< 3.99.0); sin embargo:
  El paquete `gambas3-runtime' no está instalado.

etc. etc. con todas las dependencias de gambas

El problema creo que al instalar gambas de las fuentes con:
./reconf-all
./configure -C
make
sudo make install

El sistema de paquetes de debian no lo reconoce como instalado, pero están instalados. Creo que la solución seria empaquetar Gambas 3.15 pero no me veo capacitado para hacerlo, ahora lo que hago es en el otro ordenador instalo gambas desde las fuentes y en vez de crear paquetes para debian creo el ejecutable lo copio y funciona igual.

En efecto amiguo no te esta dando resolución del problema tendrias que instalar los paquetes via apt.
Al no reconocer la instalacion manual que hiciste la opcion seria como bien dices crear los paquetes .deb a mano.
#9

(03-09-2020, 22:29)angelnu escribió:  Tengo instalado debian 10 e instale gambas3  compilándolo (versión 3.15.1) e instalándolo según la  wiki. Pero al instalarlo así, en apt no aparece instalado, creo un paquete de instalación en gambas y lo crea pero al intentar instalarlo con gdebi me dice :
Error: no se puede satisfacer la dependencia: gambas3-runtime (>=3.15).
Imagino que hay que crear los paquetes de gambas3, alguien sabe como empaquetar gambas, pues estoy pez en eso.

Hola Angelnu, supongo que usas debian estable no? es decir el paquete estable de dicha repo es el 3.12.2-1 todo otro intento de instalar por otro medio es algo arriesgado.
De todas maneras, ¿Cual es el objetivo, hacer que gambas 3.15-1 funcione en debian o empaquetar gambas 3.15 para debian?
Si es lo primero y ya lo tenes instalado en el sistema ¿Ya probaste poner gambas3 en la linea de ordenes de la terminal? si no funciona tendrías que remover todo lo creado en la instalación desde las fuentes.
Luego si en la terminal pones "locate /usr/bin/gb"  ¿Te aparece algo?
Saludos.


Posibles temas similares…
Tema / Autor Respuestas Vistas Último mensaje

Salto de foro:


Usuarios navegando en este tema: 3 invitado(s)